Buggies Gone Wild Golf Cart Forum

Buggies Gone Wild Golf Cart Forum (http://www.buggiesgonewild.com/)
-   Big Block Talk! (http://www.buggiesgonewild.com/big-block-talk/)
-   -   36 volt ezgo seems to bog down (http://www.buggiesgonewild.com/big-block-talk/76844-36-volt-ezgo-seems-bog-down.html)

bighoop68 03-05-2013 08:42 AM

36 volt ezgo seems to bog down
 
i have a 91 36 volt ezgo cart and am having somewhat of an issue with the power on this thing. fully charged, when you try to accelerate fast, it's like
the cart wants to take off but then just falls off. if you accelerate slowly then
it doesn't give me any problems. it is only when you get on it pretty hard or when taking off and trying to turn real hard on take off. i was going to redo
all of the battery wiring and also wires going to electric motor. it is almost like
i am not getting any amperage delivered to motor. any other
suggestions out there?

scottyb 03-05-2013 08:53 AM

Re: 36 volt ezgo seems to bog down
 
Check the batteries, sounds like the performance drops off after a full draw?

bighoop68 03-05-2013 09:45 AM

Re: 36 volt ezgo seems to bog down
 
batteries are brand new and it does it on a full charge


All times are GMT -5. The time now is 05:41 AM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.