lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Modified Golf Carts > Big Block Talk!
Big Block Talk! Everything about swapping a big block engine into your cart!



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-24-2014, 01:29 PM   #1
Gone Wild
 
nobuckbuild's Avatar
E-Z-GO
 
Join Date: Mar 2012
Location: CENTRAL PENNSYLVANIA
Posts: 1,466
Default evil twin cant get above 4k rpm

since i know marathon will see this and i cant find his number i will just post this here , otherwise its getting loaded on the trailers and im going to ruin one of his weekends with trying to get this thing to work. ok lets start with specs briggs 303477-1075-e1 bored .020 over new crank rods and pistons 23 hp cam with new steel pushrods and double springs with billet retainers offset timing key two barrel nikki carb with adjustable needle , cam is set normally with timing key for advance the valve are set at .005 , with no load the engine will run up to 4000 rpm and then above that it will start backfiring through the exhaust and will not get above a 4700 rpm spike , what i figured so far is that either the exhaust valves need more gap or the timing needs to be backed off , under load (driving the cart) i cannot get it over say 2400 rpm without is backfiring the exhaust and then falling flat on its face if i dont back off the pedal and yeah it is running fat as thats the only way to get it to run , compression is good as i already checked that and replaced the cylinder heads with new ones since i had an exhaust valve dropping oil down the stem before , ok well lets here what everyone has to say about opening up the valve clearence or which way to go on this one.
nobuckbuild is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-24-2014, 04:14 PM   #2
I Refuse To Get Stuck!!!
 
pachanga90's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Hamlin,NY
Posts: 5,384
Default Re: evil twin cant get above 4k rpm

I would start with the valve lash,.005 seems a bit tight on the exhaust for what you have dome to it. I could be wrong,I know that's stock spec,but maybe try .004 intake,.006 or .007" exh.Is it loosing fuel at higher rpm,and leaned out too much?How much offset on the key?I would usually start with about a #3, then work from there.A Cyl.temp gauge tells a lot too.Is the valve-guide too tight?That will cause it to hang as it gets hotter..
pachanga90 is offline   Reply With Quote
Unread 03-24-2014, 04:18 PM   #3
I Refuse To Get Stuck!!!
 
pachanga90's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Hamlin,NY
Posts: 5,384
Default Re: evil twin cant get above 4k rpm

Is the timing key in the correct direction?I've seen it backwards,and it retards the timing,it will run,but no power,and no rpm capability.
pachanga90 is offline   Reply With Quote
Unread 03-24-2014, 04:24 PM   #4
Gone Wild
 
Join Date: Oct 2010
Posts: 6,730
Default Re: evil twin cant get above 4k rpm

If I had only one guess, I'd say the timing key is installed backwards.
1989Marathon is offline   Reply With Quote
Unread 03-24-2014, 06:00 PM   #5
Gone Wild
 
nobuckbuild's Avatar
E-Z-GO
 
Join Date: Mar 2012
Location: CENTRAL PENNSYLVANIA
Posts: 1,466
Default Re: evil twin cant get above 4k rpm

ok opened the valves to .006 and opened the fuel a good bit and now she is smooth up to 4500 before we start backfire im thinking that i need to trim the fuel back some and i think we are getting into the valve float area due to the steel pushrods , i know that the key is right as i had pulled the engine before to double check it and also checked it against the directions so thats ruled out , don i know you told someone else how to set up the needle i just cannot find it and i figure any instruction would be better than guess work and thanks everyone
nobuckbuild is offline   Reply With Quote
Unread 03-24-2014, 06:09 PM   #6
Gone Wild
 
Join Date: Oct 2010
Posts: 6,730
Default Re: evil twin cant get above 4k rpm

What rpm are you getting when you load the motor?
Did you remove the main jet from the carb?
Before I installed the supercharger, I had the needle about 2-turns out.
Are both cylinders firing? Feel the valve covers.
1989Marathon is offline   Reply With Quote
Unread 03-24-2014, 08:39 PM   #7
Gone Wild
 
nobuckbuild's Avatar
E-Z-GO
 
Join Date: Mar 2012
Location: CENTRAL PENNSYLVANIA
Posts: 1,466
Default Re: evil twin cant get above 4k rpm

im guessing your right on the jet i had replaced it looking for the problem , but im thinking about just opening up the jet some to get the top end up just a little so i can have my 44-4500 rpm top end without leaning it out , any opinion on that sort of being a limiter as i know some people don't understand or go deaf when you tell them keep it under 5000 rpm i figure open it up to get to 5500 rpm and then i should be safe and not lean out at 4500

also what fluid in the me29 30w or 80-90w
nobuckbuild is offline   Reply With Quote
Unread 03-25-2014, 06:57 AM   #8
Gone Wild
 
Join Date: Oct 2010
Posts: 6,730
Default Re: evil twin cant get above 4k rpm

If you are using the main jet to limit the rpm, that's a sure way to grenade the motor. Remove the main jet completely, and limit the speed by other means.
I am using 90w in the transaxle.
1989Marathon is offline   Reply With Quote
Unread 03-30-2014, 08:28 AM   #9
72 volts!
 
Andy4639's Avatar
E-Z-GO
 
Join Date: Jan 2007
Location: Liberty SC, Garden City SC
Posts: 5,412
Wink Re: evil twin cant get above 4k rpm

I have been fighting this as well. After putting the valve springs and such in mine. Here is what I found yesterday.

One, the front coil was cutting in and out at about 4000 RPM's at lower rpms it was fine but over 4 it would start doing this. Replaced it with a used one and it went right up to 5-5500RPM's.

Second,
Air filter was not letting it breath correctly, don't ask me how are why but when I got the cart it had a scotch brite pad for the filter, I replaced it with a lawnmower filter, (green foam) well it just wouldn't run right so yesterday i put a new scotch brite pad back in it and she is jumping to 5-6RPMs now with no problems.
This is a 20HP V- twin Bandolero motor best I can tell.
Andy4639 is offline   Reply With Quote
Unread 03-30-2014, 11:35 AM   #10
Vegas modded 420
 
sho305's Avatar
Yamaha
 
Join Date: Jun 2009
Location: West MI
Posts: 14,540
Default Re: evil twin cant get above 4k rpm

Any change in flow to the airbox/filter or the exhaust will change jetting.

In my experience lean will run more rpm on the top end, but depends on how the carb is working, I've had that with stock lawn carbs. The engine needs proper jetting to run best, above all.

With better springs just about any lawn engine used for this stuff should run 6K without float (if it can get there) unless your springs are not for your aftermarket cam.
sho305 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Modified Golf Carts > Big Block Talk!


Thread Tools
Display Modes


Similar Threads
Thread Forum
Briggs V-Twin - Twin Carburettor Question Big Block Talk!
V-Twin Golf Carts and Parts
v twin Golf Carts and Parts
solenoids are evil things Electric Yamaha


All times are GMT -5. The time now is 07:07 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.