lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Modified Golf Carts > Big Block Talk! > Clone Engine Swaps


Post New Thread  Reply
Thread Tools Display Modes
Unread 07-31-2019, 07:36 PM   #1
Not Yet Wild
 
Join Date: Jul 2019
Posts: 5
Default Electrical Help Needed Predator 420

Just put a new Predator 420 in my Gas 89 Club Car Ds, purchased the Vegas carts conversion kit, now hooking up the electrical. This is my first go round with a golf cart and I am no electrician. We can't get it to start, we can jump at the solenoid and it starts but won't do anything when pressing gas n key on Can someone please direct me on if I need the old ignition coil, or what and where i need to hook the starter generator wires too, I have a yellow wire I am unsure of. We left the existing wiring and are using the original starter generator. We are trying to keep it stock with the gas start, we took off the starter and key start from the new motor. Thank you in advance as I am going crazy and want this thing to run!
Shaugland is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-02-2019, 06:32 PM   #2
Not Yet Wild
 
Join Date: Jul 2019
Posts: 6
Default Re: Electrical Help Needed Predator 420

I've tried getting this info for a month now. No luck. So here's what I've done.
Found diagrams for my txt and the predator...
Seen and found all the wires.

I've connected my starter generator to the solenoid and ignitor coils.
But still lost about where to put the pedal start wires. and which wires got to the 420 pulsar coil?
The old engine had 2 spark plugs and a new engine only has one.
Ive tried to pull starting the engine and it won't start either. I will donate to site if someone can direct me to geting this thing fired up.
coachgkj2 is offline   Reply With Quote
Unread 08-02-2019, 07:02 PM   #3
VC 460 CLONE GONE WILD
 
raydhd's Avatar
Yamaha
 
Join Date: Oct 2014
Location: Ray BY The Bay NJ
Posts: 6,021
Default Re: Electrical Help Needed Predator 420

ONE MORE TIME. 1) The clone engine needs nothing from the cart but a fuel supply and a means to shut it down. 2) The S/G is not changed at all for the clone. It operates just as it did with the stocker. A really good idea is to run the clone engine before installing it in the cart. As far as I know all of them have a pull starter. Try it.
raydhd is offline   Reply With Quote
Unread 08-05-2019, 09:43 AM   #4
Not Yet Wild
 
Join Date: Jul 2019
Posts: 5
Default Re: Electrical Help Needed Predator 420

Thanks Raydhd, ours starts when jumping the Solenoid but won't pedal start or key start. We are unsure of the wiring, we think it's right but are not sure since it won't start or turn over.
Shaugland is offline   Reply With Quote
Unread 08-06-2019, 05:14 PM   #5
Not Yet Wild
 
Join Date: Jul 2019
Posts: 6
Default Re: Electrical Help Needed Predator 420

Quote:
Originally Posted by raydhd View Post
ONE MORE TIME. 1) The clone engine needs nothing from the cart but a fuel supply and a means to shut it down. 2) The S/G is not changed at all for the clone. It operates just as it did with the stocker. A really good idea is to run the clone engine before installing it in the cart. As far as I know all of them have a pull starter. Try it.
Thanks again it was a carb issue now fixed and starting by pull start. Now finding where to wire the pedal start.
coachgkj2 is offline   Reply With Quote
Unread 08-06-2019, 05:52 PM   #6
VC 460 CLONE GONE WILD
 
raydhd's Avatar
Yamaha
 
Join Date: Oct 2014
Location: Ray BY The Bay NJ
Posts: 6,021
Default Re: Electrical Help Needed Predator 420

Go to the gas EZGO site and someone there will direct you to how the stock S/G should be wired. AGAIN the clone has nothing to do with the S/G wiring only get spun by it just as it was in the stocker.
raydhd is offline   Reply With Quote
Unread 08-08-2019, 05:51 PM   #7
Gone Wild
Club Car
 
Join Date: Aug 2010
Location: Central Florida
Posts: 937
Default Re: Electrical Help Needed Predator 420

If you are using the factory club car starter generator and have removed the wiring from the predator your wiring should still be the same as factory club car. Just need to remove the engine kill wire that went to the factory engine and attach it to the lead going to the coil of the predator engine. Also shows wiring for the starter generator.
Attached Images
File Type: jpeg EF9434B9-E839-4516-BC8F-6F65EE2CFC18.jpeg (101.4 KB, 0 views)
KRAZYMATT is offline   Reply With Quote
Unread 08-09-2019, 05:45 PM   #8
Not Yet Wild
 
Join Date: Jul 2019
Posts: 5
Default Re: Electrical Help Needed Predator 420

Got it running for awhile. Then it died, replaced the battery and still nothing. 1 step forward 2 steps back, lol. Trying to read up and figure out how to test everything, new solenoid and new battery. Any suggestions, it jumps from the Solenoid and starts but not pedal start and it did just fine last night.
Shaugland is offline   Reply With Quote
Unread 08-11-2019, 07:44 AM   #9
Gone Wild
Club Car
 
Join Date: Aug 2010
Location: Central Florida
Posts: 937
Default Re: Electrical Help Needed Predator 420

Could it possibly be in maintence mode? have tou tried starting it in neutral, or in gear forward/reverse?

Look at the wiring diagram posted above. sounds like one of the microswitches is acting up. there are 2 on the back of the gear selector switch, one that will not let it start unless its in forward or reverse, will not start in neutral unless it is in maintence mode. the other microswitch there operates the reverse buzzer and will not affect the starting. the other 2 will be in the black box where the solenoid, voltage regulator, and throttle connections are. one enablesx whe solenoid when the pdeal is pressed, but the gear selector must not be in maintence mode. the other one grounds the coil when the pedal is not pressed.

Maintence mode.
behind the gear shifter is a round plastic cam with a spring. you can pull back on it and spin it 180 degrees. this will allow you to start the cart in neutral for testing, however it will do nothing if forward or reverse. to remove it from maintence mode pull back o it and spin it 180 degree back, no it will only start/run in forward or reverse, not neutral.

Either way sounds like you have an issue with the microswitches if it starts when you jump the coil. once it starts when you jump the coil does it stay running and stop when you let off the pedal?
KRAZYMATT is offline   Reply With Quote
Unread 08-12-2019, 07:27 PM   #10
Not Yet Wild
 
Join Date: Jul 2019
Posts: 5
Default Re: Electrical Help Needed Predator 420

Thank you for pointing out the simple things, it was the maintenance mode, we thought we had checked it once but failed to double check it. Now on to the carb, can you tell me how the pulse line is to be hooked up. It dies out under load like it's not getting gas but fuel line and filter are full. Thanks so much for everyone's help!!
Shaugland is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Modified Golf Carts > Big Block Talk! > Clone Engine Swaps


Thread Tools
Display Modes


Similar Threads
Thread Forum
Replacement cylinder head for Predator 420cc Hemi needed Clone Engine Swaps
36v Electrical info needed HELP Electric Yamaha
Predator Carb Help needed! Clone Engine Swaps
Electrical help NEEDED BAD Electric EZGO
Electrical help needed? Electric Club Car


All times are GMT -5. The time now is 03:13 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.