lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Modified Golf Carts > Big Block Talk! > Clone Engine Swaps


Post New Thread  Reply
Thread Tools Display Modes
Unread 08-05-2019, 11:35 AM   #1
Not Yet Wild
 
tommywilder's Avatar
 
Join Date: Apr 2016
Posts: 11
Angry Not much speed after new 420 and clutch - TXT on 28s

Finally going to break down and ask for help. Specifically because this weekend is the local golf cart mud races. I am desperate to do better than normal this year.

Current situation: Just pulled my GX390 after some noise and found too much side play in the rod bearing. Replaced with a Predator 420 Hemi and Comet 780. Only mods to engine are cone air filter and exhaust (tractor muffler.) After getting the engine in, I did try a couple other jets - 41 and 42, but pulled the plug afterwards and it was completely covered in soot. (This is after riding only about 1/2 mile to test for speed, mind you.) Never had one foul that quick before.

EZ-GO TXT (95, I think?) on 28" Super Swampers and a LOT of homemade lift.

I am seeing 25mph. What can I do to get that number up and keep (or gain) some torque in a quick fashion? I only have 3 days to get this thing ready.

Thanks!
tommywilder is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-05-2019, 01:05 PM   #2
Gone Wild
Club Car
 
Join Date: Sep 2018
Location: Michigan
Posts: 164
Default Re: Not much speed after new 420 and clutch - TXT on 28s

How old is your belt and how wide is it? Do you have a main jet adjuster installed?
superpro56 is offline   Reply With Quote
Unread 08-05-2019, 01:12 PM   #3
Not Yet Wild
 
tommywilder's Avatar
 
Join Date: Apr 2016
Posts: 11
Default Re: Not much speed after new 420 and clutch - TXT on 28s

Unfortunately I don't have a jet adjuster, but I do have a bunch of jets (small and large) and hobby bits. Thinking I'll try going a little leaner this evening and see how it does.

Belt is getting aged. Any idea what a Gates or other locally-available belt part number would be for stock size?

What kind of speed should I see with the setup that I have, as in, how much am I actually missing?
tommywilder is offline   Reply With Quote
Unread 08-05-2019, 01:59 PM   #4
Gone Wild
Club Car
 
Join Date: Sep 2018
Location: Michigan
Posts: 164
Default Re: Not much speed after new 420 and clutch - TXT on 28s

Definitely sounds rich, work with what you have for the upcoming event. For the future, get one of these

https://www.eccarburetors.com/169F-4...rb_p_1212.html

Assuming 12 to 1 ratio rear end and 4000 rpms, it works out to 27mph. You can check it out here and plug in different numbers as far as RPM or axle ratio to see how it may impact your final speed.

http://www.buggiesgonewild.com/speed-calculator.php

Not much help on the belt, the 780 is compatible with either a 1-1/4 or 1-3/16 width belt.
superpro56 is offline   Reply With Quote
Unread 08-05-2019, 02:27 PM   #5
Crazy Ole Man
 
Shepard's Avatar
Yamaha
 
Join Date: Jan 2016
Location: Owego NY
Posts: 2,356
Default Re: Not much speed after new 420 and clutch - TXT on 28s

Quote:
Originally Posted by tommywilder View Post
Finally going to break down and ask for help. Specifically because this weekend is the local golf cart mud races. I am desperate to do better than normal this year.

Current situation: Just pulled my GX390 after some noise and found too much side play in the rod bearing. Replaced with a Predator 420 Hemi and Comet 780. Only mods to engine are cone air filter and exhaust (tractor muffler.) After getting the engine in, I did try a couple other jets - 41 and 42, but pulled the plug afterwards and it was completely covered in soot. (This is after riding only about 1/2 mile to test for speed, mind you.) Never had one foul that quick before.

EZ-GO TXT (95, I think?) on 28" Super Swampers and a LOT of homemade lift.

I am seeing 25mph. What can I do to get that number up and keep (or gain) some torque in a quick fashion? I only have 3 days to get this thing ready.

Thanks!
Have you removed the governor? You should be able to get up to 41-4200 rpm safely. Make sure you have some type of tachometer.
Shepard is offline   Reply With Quote
Unread 08-05-2019, 03:07 PM   #6
Not Yet Wild
 
tommywilder's Avatar
 
Join Date: Apr 2016
Posts: 11
Default Re: Not much speed after new 420 and clutch - TXT on 28s

I have not removed the governor on this one. Not brave enough until after this weekend. Haha My GX390 that this replaced was degoverned. Appreciate the info on the adjustable jet and that calculator. I'll need to figure out what my ratio is this evening.
tommywilder is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Modified Golf Carts > Big Block Talk! > Clone Engine Swaps


Thread Tools
Display Modes


Similar Threads
Thread Forum
1987 easygo gas speed varies bad clutch? Gas EZGO
G2 secondary clutch spring upgrade vs top end speed Gas Yamaha
EZ-GO clutch adjustment & idle speed Clone Engine Swaps
clutch power kit and speed spring Gas Yamaha
Machining Clutch/s and Speed Gas Club Car


All times are GMT -5. The time now is 11:02 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.