lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-05-2015, 08:30 PM   #1
Getting Wild
 
Jamesotn's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Alcoa Tn near the smokey mountains
Posts: 118
Question o8 CC shuttle takes off good then slows

Installed 8 new 6 volt batteries. Ran good several blocks. Next time I took it out it took off good, then slowed to 1/4 speed. Replaced speed sensor...no change...it has the IQ system shifter on dash.

Any ideas ?? Thanks
Jamesotn is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-06-2015, 03:46 PM   #2
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,961
Default Re: o8 CC shuttle takes off good then slows

Check the circuit breaker next to the tow and run switch. If it's tripped it can trigger low speed. If that doesn't fix it you're going to have to scan it. The IQ Plus system is very complex.
TahoeDawgZ71 is offline   Reply With Quote
Unread 01-06-2015, 05:33 PM   #3
Getting Wild
 
Jamesotn's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Alcoa Tn near the smokey mountains
Posts: 118
Question Re: o8 CC shuttle takes off good then slows

O.K. so breaker is no t open....don't know what mcor means, but at the end of a shaft attached to my accellerator pedal is a black box, with two different sets of wires going into it. The problem seems to be there. No numbers or markings on the box. So do I understand correctly they discontinued this specific box?
The pedals on the shuttle are semi smooth and have deep " stop and go " letters in them. This is the QS 6 shuttle.

Thanks
Jamesotn is offline   Reply With Quote
Unread 01-06-2015, 05:37 PM   #4
DS Drivers Club Founder
 
CCFanatic's Avatar
Club Car
 
Join Date: Jul 2013
Location: Upstate NY
Posts: 3,408
Default Re: o8 CC shuttle takes off good then slows

That box is the MCOR. Unless I am missing something with the IQ plus system, a defective MCOR will not trigger 1/4 speed
CCFanatic is offline   Reply With Quote
Unread 01-06-2015, 05:52 PM   #5
Getting Wild
 
Jamesotn's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Alcoa Tn near the smokey mountains
Posts: 118
Default Re: o8 CC shuttle takes off good then slows

This happens within 3-4 seconds....found one on ebay $149 worth a shot

Thanks
Jamesotn is offline   Reply With Quote
Unread 01-06-2015, 05:58 PM   #6
DS Drivers Club Founder
 
CCFanatic's Avatar
Club Car
 
Join Date: Jul 2013
Location: Upstate NY
Posts: 3,408
Default Re: o8 CC shuttle takes off good then slows

Please provide a link for the MCOR you are referring to. If it is a Precedent MCOR, it wouldn't work. You need a DS / Carryall MCOR
CCFanatic is offline   Reply With Quote
Unread 01-06-2015, 06:49 PM   #7
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: o8 CC shuttle takes off good then slows

Maybe this will help. It helped me.

MCOR / Pedal Assembly Confusion Explained
jjance is offline   Reply With Quote
Unread 01-06-2015, 07:41 PM   #8
Getting Wild
 
Jamesotn's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Alcoa Tn near the smokey mountains
Posts: 118
Default Re: o8 CC shuttle takes off good then slows

This is the correct MCOR for 2008 club car ds Qs6 shuttle w/ IQ. It is an exact match of what I removed from the cart an hour ago

http://www.ebay.com/itm/271648357666...ageName=STRK%3

Thanks again for all your effort and time.
Jamesotn is offline   Reply With Quote
Unread 01-06-2015, 07:44 PM   #9
Getting Wild
 
Jamesotn's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Alcoa Tn near the smokey mountains
Posts: 118
Default Re: o8 CC shuttle takes off good then slows

And one more time can anyone walk me thru how to post a picture of my cart like jjance has >?/? I have followed all previous instructions and nothing happens.... possible the jpg is too big ? Not wild yet...do I need to make another donation ?
Jamesotn is offline   Reply With Quote
Unread 01-06-2015, 07:59 PM   #10
DS Drivers Club Founder
 
CCFanatic's Avatar
Club Car
 
Join Date: Jul 2013
Location: Upstate NY
Posts: 3,408
Default Re: o8 CC shuttle takes off good then slows

That is the correct MCOR. As for the avatar change:

Click on your name in the upper right hand corner (click on pictures to enlarge)
Untitled.jpg

Then click on Customize profile
Untitled 2.jpg

Then click Edit Avatar
Untitled 3.jpg

Select your picture and you are good to go
Untitled 4.jpg
CCFanatic is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
ezgo txt takes off fast then slows to crawl Electric EZGO
85 gas ezgo takes 20-30 seconds to get WOT Gas EZGO
cart jumps before it takes off Gas EZGO
04 CC takes off normal then slows down. Electric Club Car
91 CC Takes Off In Reverse Electric Club Car


All times are GMT -5. The time now is 12:02 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.