lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-11-2015, 08:06 PM   #1
Not Yet Wild
 
bdmills's Avatar
Club Car
 
Join Date: Aug 2014
Location: Spartanburg SC
Posts: 12
Default Charger not cutting off

I will start off with what i have done. I installed #2 gauge wire upgrade. I ran 2 gauge wire on all batteries and all the way back to controller. I ran 2 gauge from solenoid to controller and from controller all the way to the motor. This is on a 2009 Precedent. Fyi my main neg wire runs threw the obc and since the #2 wire would not i installed a brass all thread rod threw hole and installed 2 brass nuts on both sides to hook neg wire to. After all that cart runs fine but when i hooked it up to charge it charges but will not cut off. Did i do something wrong .
bdmills is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-11-2015, 08:53 PM   #2
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,976
Default Re: Charger not cutting off

Not 100% sure but I think you need to put rubber washers next to OBC when using the stud. The nuts or stud is not supposed to contact metal of OBC.
mrgolf is offline   Reply With Quote
Unread 01-11-2015, 08:56 PM   #3
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: Charger not cutting off

Should have used something like this.
Attached Images
File Type: jpg OBC Battery Stud.jpg (44.9 KB, 0 views)
jjance is offline   Reply With Quote
Unread 01-11-2015, 09:37 PM   #4
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 4,579
Default Re: Charger not cutting off

The very first charge would have taken longer since the OBC reset while power was disconnected.

If it still running long, check some basics first like making sure the charger receptacle red wire was connected back to the pack positive.
Sergio is online now   Reply With Quote
Unread 01-12-2015, 09:27 AM   #5
Not Yet Wild
 
bdmills's Avatar
Club Car
 
Join Date: Aug 2014
Location: Spartanburg SC
Posts: 12
Default Re: Charger not cutting off

I did use rubber washers against the obc but not rubber on stud going threw obc. The red wire is connected to positive.
bdmills is offline   Reply With Quote
Unread 01-12-2015, 09:31 AM   #6
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,068
Default Re: Charger not cutting off

Did you bore out the OBC hole or squeeze the OBC with the install stud and nuts?

And most importantly, what is the pre-charge reading & pack voltage when the charger has been on for 8 hours?
scottyb is online now   Reply With Quote
Unread 01-12-2015, 09:33 AM   #7
Not Yet Wild
 
bdmills's Avatar
Club Car
 
Join Date: Aug 2014
Location: Spartanburg SC
Posts: 12
Default Re: Charger not cutting off

No. I used 3/8 all thread and it went right threw and no i made sure not to squeeze the obc
bdmills is offline   Reply With Quote
Unread 01-12-2015, 09:35 AM   #8
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,068
Default Re: Charger not cutting off

Quote:
Originally Posted by bdmills View Post
No. I used 3/8 all thread and it went right threw and no i made sure not to squeeze the obc
Sounds good - voltage readings then?
scottyb is online now   Reply With Quote
Unread 01-12-2015, 09:41 AM   #9
Not Yet Wild
 
bdmills's Avatar
Club Car
 
Join Date: Aug 2014
Location: Spartanburg SC
Posts: 12
Default Re: Charger not cutting off

It was late and i didn't check reading but can when i get back home. Just because i didnt put rubber on stud. Will that cause this?
bdmills is offline   Reply With Quote
Unread 01-12-2015, 11:18 AM   #10
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,068
Default Re: Charger not cutting off

no.
scottyb is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
club car precedent charger is cutting off before meter shows 0 Electric Club Car
G29 cutting out Gas Yamaha
Club car charger cutting off Electric Club Car
Par car cutting out Gas Columbia ParCar
97 G16 Cutting out at WOT Gas Yamaha


All times are GMT -5. The time now is 09:28 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.