lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-23-2015, 11:39 AM   #1
Not Yet Wild
 
toddblazer's Avatar
Club Car
 
Join Date: Jul 2014
Posts: 12
Default Precedent 2011 battery issues

All
Ive had my cart for 6 months and has ran flawlessly over this period. In the last 2 months my cart has lost both speed and battery longevity.

Fresh off a charge the batteries read 8.5 for all 6 (8 volt batteries).

Going for a 10 minute drive both up and down hills, the battery meter will read 1/2 full and the batteries show at 8.0 to 7.9 across the board.

The slower than normal speed is immediate, going down hill I could get 32 mph back in September, and now its top end of 27. on flat ground I was seeing 24 mph, now its 19.

Ive unconnected the batteries and re-connected and still not seeing any improvement.

any thoughts what to check next?
toddblazer is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-23-2015, 10:02 PM   #2
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: Precedent 2011 battery issues

Quote:
what to check next
Check the water (electrolyte) level. My battery voltage is about 46 v under load. When you unplug your charger does your amber dash light flash. When your batteries start bubbling take the tops off and make sure all of them are bubbling. I'm thinking you have a bad battery.
jjance is offline   Reply With Quote
Unread 01-23-2015, 11:20 PM   #3
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,025
Default Re: Precedent 2011 battery issues

Tire pressure and front end alignment.
TahoeDawgZ71 is offline   Reply With Quote
Unread 01-24-2015, 10:06 AM   #4
Gone Wild
 
scooterman's Avatar
Club Car
 
Join Date: Jan 2014
Location: Lafayette, Louisiana
Posts: 1,642
Default Re: Precedent 2011 battery issues

How old are your batteries? Load test is probably required at this point. After you charge the cart, let your batteries set 12 hours then read the voltage.
scooterman is offline   Reply With Quote
Unread 01-24-2015, 05:58 PM   #5
Not Yet Wild
 
toddblazer's Avatar
Club Car
 
Join Date: Jul 2014
Posts: 12
Default

Batteries I think are 9 months old. Tire pressure is 20 lbs. Charged overnight and just checked the levels and it reads 8.4 (4 batteries) 8.3 (2 batteries)
toddblazer is offline   Reply With Quote
Unread 01-24-2015, 05:59 PM   #6
Not Yet Wild
 
toddblazer's Avatar
Club Car
 
Join Date: Jul 2014
Posts: 12
Default

Will check electrolytes tomorrow and try a load test. Thanks for your suggestions
toddblazer is offline   Reply With Quote
Unread 01-24-2015, 09:07 PM   #7
Gone Wild
 
scooterman's Avatar
Club Car
 
Join Date: Jan 2014
Location: Lafayette, Louisiana
Posts: 1,642
Default Re: Precedent 2011 battery issues

Quote:
Originally Posted by toddblazer View Post
Will check electrolytes tomorrow and try a load test. Thanks for your suggestions
Test them, it is the first thing I would do. Eliminate the batteries test them well each cell.
scooterman is offline   Reply With Quote
Unread 01-25-2015, 02:15 PM   #8
Not Yet Wild
 
toddblazer's Avatar
Club Car
 
Join Date: Jul 2014
Posts: 12
Default

Each cell was either recharge or the low end of fair on the hydrometer. Sounds like new batteries are in my future
toddblazer is offline   Reply With Quote
Unread 01-25-2015, 03:38 PM   #9
Gone Wild
 
scooterman's Avatar
Club Car
 
Join Date: Jan 2014
Location: Lafayette, Louisiana
Posts: 1,642
Default Re: Precedent 2011 battery issues

Quote:
Originally Posted by toddblazer View Post
Each cell was either recharge or the low end of fair on the hydrometer. Sounds like new batteries are in my future

You said above the batteries were about 9 months old,. if this is trues then something is wrong, these are Golf cart batteries not deep cycle correct?
scooterman is offline   Reply With Quote
Unread 01-25-2015, 04:29 PM   #10
Gone Wild
 
teecro's Avatar
Club Car
 
Join Date: Jun 2014
Location: Sunset Bay, TN
Posts: 2,214
Default Re: Precedent 2011 battery issues

Quote:
Originally Posted by scooterman View Post
You said above the batteries were about 9 months old,. if this is trues then something is wrong, these are Golf cart batteries not deep cycle correct?
Bet he was told a "little white lie" about the batteries age when he bought the cart.... Check the date code on the batteries....
teecro is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2011 ezgo 6 seater motor issues Gas EZGO
2011 Precedent Charging Issues Electric Club Car
2011 Club Car Battery Issues Electric Club Car
Battery/Charger Issues with 2005 Precedent Electric Club Car
Battery Issues with Precedent ??? Electric Club Car


All times are GMT -5. The time now is 04:40 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.