lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-22-2015, 10:08 AM   #11
Ban Puppy Mills & Stores!
 
scubabud's Avatar
Club Car
 
Join Date: Dec 2008
Location: SE Florida
Posts: 2,945
Default Re: Stuck without a ride! Precedent lurches then rolls to a stop

The paperclip is what is in my text above and very easy to do, taking under 5 minutes to accomplish for testing and a fix until the relatives leave.

The thread on REBUILDING a MCOR is here:

Inside An MCOR 01-04 DS

Do yourself a favor first and try the paperclip to make sure that the MCOR is the problem. In order to rebuild the MCOR you're going to have to do everything that it would take to just replace it with a new one, but if you're handy at fixing things, it could save you money, if it worked.
scubabud is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-22-2015, 10:08 AM   #12
Not Yet Wild
 
Join Date: Feb 2015
Posts: 30
Default Re: Stuck without a ride! Precedent lurches then rolls to a stop

There are two plugs on the side of the mcor facing my f/r switch. Are you referencing the top plug shaped like a square? The lower is shaped like a triangle if I remember correctly. I also saw you mentioned a DS in your thread. My cart is a Precedent.....does that make a difference? Thanks again! This forum is awesome....
Camogolfcart is offline   Reply With Quote
Unread 02-22-2015, 10:15 AM   #13
Ban Puppy Mills & Stores!
 
scubabud's Avatar
Club Car
 
Join Date: Dec 2008
Location: SE Florida
Posts: 2,945
Default Re: Stuck without a ride! Precedent lurches then rolls to a stop

The link I listed on repairing a MCOR was written by a member that has a DS, but the same MCOR. I never mentioned a DS other then listing the thread for you.

The top plug on a MCOR is the two wire, more square looking plug that should have a purple and green wire attached.

What year is your Precedent?
scubabud is offline   Reply With Quote
Unread 02-22-2015, 10:53 AM   #14
Not Yet Wild
 
Join Date: Feb 2015
Posts: 30
Default Re: Stuck without a ride! Precedent lurches then rolls to a stop

Scubabud, I tried your paperclip trick but unfortunately the problem persists. I'm open to any more direction/advice. Serial number is pq0834-948128, is that an '08? Thanks again.
Camogolfcart is offline   Reply With Quote
Unread 02-22-2015, 11:18 AM   #15
Ban Puppy Mills & Stores!
 
scubabud's Avatar
Club Car
 
Join Date: Dec 2008
Location: SE Florida
Posts: 2,945
Default Re: Stuck without a ride! Precedent lurches then rolls to a stop

If it's not the MCOR then it could be the solenoid, controller, wiring issues... many things. There are others here on BGW that have way more expertise on these issues. Hopefully someone else would chime in.

Yes, your cart is an 08 Precedent.

You're sure that you had a good connection using a large paperclip in the two holes of the connector???
scubabud is offline   Reply With Quote
Unread 02-22-2015, 11:22 AM   #16
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 4,583
Default Re: Stuck without a ride! Precedent lurches then rolls to a stop

Quote:
Originally Posted by Camogolfcart View Post
The cart will run for a while at a crawl with the accelerator barely engaged then when I try to get it up to speed it feels like its jumping out of gear.
You need to make sure the problem is not the battery pack.

Set Your meter to 200vDC and measure the lowest voltage reading while driving the cart, specially when it feels like is cutting off.

The micro switch part of the MCOR would not cause a "crawl" symptom.

If the battery pack measures OK, the MCOR resistance track could cause that problem.

With the key off, press the pedal to the floor and up several times. This sometimes cleans any oxidation that may exist in the MCOR wiper track.

If the battery pack drops too low, check each individual battery while driving.

Set the meter to 20vDC when testing individual batteries.
Sergio is online now   Reply With Quote
Unread 02-22-2015, 11:56 AM   #17
Ban Puppy Mills & Stores!
 
scubabud's Avatar
Club Car
 
Join Date: Dec 2008
Location: SE Florida
Posts: 2,945
Default Re: Stuck without a ride! Precedent lurches then rolls to a stop

Sergio,

If the micro switch never made it's contact when the pedal was pushed then the cart shouldn't move at all correct? The solenoid would never engage? The cart would never jump?
scubabud is offline   Reply With Quote
Unread 02-22-2015, 12:31 PM   #18
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 4,583
Default Re: Stuck without a ride! Precedent lurches then rolls to a stop

Quote:
Originally Posted by scubabud View Post
Sergio,

If the micro switch never made it's contact when the pedal was pushed then the cart shouldn't move at all correct? The solenoid would never engage? The cart would never jump?
Correct, if the Micro switch disengages while the cart is running (key switch ON), it would behave as a Pedal up brake and regen would engage.

If the micro-switch would then close again, if the pedal was more than 25% pressed at the time, the cart would continue on Regen until it stopped.

If the Pedal was less than 25% pressed and the micro-switch closed again, it would continue to run just as if You had pressed the pedal back down.

If the battery pack is not dropping voltage under load, my next guess would be the Solenoid contacts being worn out.
Sergio is online now   Reply With Quote
Unread 02-22-2015, 01:22 PM   #19
Not Yet Wild
 
Join Date: Feb 2015
Posts: 30
Default Re: Stuck without a ride! Precedent lurches then rolls to a stop

In case I followed directions poorly.....you intended for the paper clip to be inserted in the male end of the harness/plug and not the female/receiving end of the Mcor....correct?
Camogolfcart is offline   Reply With Quote
Unread 02-22-2015, 01:30 PM   #20
DS Drivers Club Founder
 
CCFanatic's Avatar
Club Car
 
Join Date: Jul 2013
Location: Upstate NY
Posts: 3,409
Default Re: Stuck without a ride! Precedent lurches then rolls to a stop

Quote:
Originally Posted by Camogolfcart View Post
In case I followed directions poorly.....you intended for the paper clip to be inserted in the male end of the harness/plug and not the female/receiving end of the Mcor....correct?
Correct, with the paper clip, you jump the two-pin harness side plug
CCFanatic is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
WTB 1983+ Royal Ride Rolls Royce Golf Cart 4 seater Golf Carts and Parts
precedent stop and go problem Electric Club Car
2008 precedent stuck in reverse Electric Club Car
2008 Precedent that rolls freely Electric Club Car
Precedent motor stuck Electric Club Car


All times are GMT -5. The time now is 03:50 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.