lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-25-2015, 08:40 AM   #1
Not Yet Wild
 
scooper77515's Avatar
Club Car
 
Join Date: Aug 2013
Location: On a ranch east of Houston
Posts: 61
Default 08 Precedent sometimes pedal doesn't work first time

Might be beating a dead horse and asking a very common question, but I did a search and did not find similar symptoms anywhere else.

All new batteries, so let's get that out of the way.

This cart is usually flawless. I drive it on average 5 miles per day out in cow pasture, 3-5 days per week.

But sometimes, when I step on the GO pedal, nothing. Usually when I first drive it that day. I have noticed that if I gently kick up on the dash board, it will go, but yesterday, even that did not work (might just be coincidence)

But if I stomped hard full throttle, it would go and then act normal.

Does this in Forward and Reverse.

Where should I start looking?

Speed sensor?
scooper77515 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-25-2015, 10:42 AM   #2
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,974
Default Re: 08 Precedent sometimes pedal doesn't work first time

Look for loose connections, key switch forward reverse wiring under cart pulled loose. You may have ran over a stick or something that pulled on the wiring.
mrgolf is offline   Reply With Quote
Unread 02-25-2015, 03:22 PM   #3
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: 08 Precedent sometimes pedal doesn't work first time

Did you try kicking the tires sometimes that works. Just kidding I'd start with the MCOR. :)
jjance is offline   Reply With Quote
Unread 02-25-2015, 03:49 PM   #4
Getting Wild
Club Car
 
Join Date: Jun 2013
Location: Sugar Land, TX
Posts: 126
Default Re: 08 Precedent sometimes pedal doesn't work first time

I second the MCOR. Not terribly difficult to change out. When they start to go bad, it can be terribly frustrating and a lot of times sends people to other more complex and expensive conclusions that don't pan out.
smackdaddy66 is offline   Reply With Quote
Unread 02-25-2015, 03:55 PM   #5
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,042
Default Re: 08 Precedent sometimes pedal doesn't work first time

The MCOR has a micro switch in it that triggers the solenoid. The ms can fail in an intermittent pattern. Does the solenoid click when the cart doesn't go?
scottyb is offline   Reply With Quote
Unread 02-25-2015, 05:01 PM   #6
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,960
Default Re: 08 Precedent sometimes pedal doesn't work first time

I agree with the others. It sounds like the classic symptoms of an MCOR failure. Remove the rubber floormat from the vehicle. Remove the plastic access door from the floor. You'll be able to see the wires that plug into the MCOR. There is a two-pin connector and a three-pin connector. Un-plug the two pin connector from the mcor and jump the pins together with a paperclip or a piece of wire. This will bypass the internal micro switch of the MCOR. If the car operates normally with the jumper in place, replace the MCOR.
TahoeDawgZ71 is offline   Reply With Quote
Unread 02-25-2015, 05:29 PM   #7
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: 08 Precedent sometimes pedal doesn't work first time

Tahoe, I often wondered about something. If you jumper the sw out before you turn the key switch on will you get a HPD. What I'm trying to say is turn the key sw on first and then jumper the MCOR switch.
jjance is offline   Reply With Quote
Unread 02-25-2015, 05:51 PM   #8
Not Yet Wild
 
scooper77515's Avatar
Club Car
 
Join Date: Aug 2013
Location: On a ranch east of Houston
Posts: 61
Default Re: 08 Precedent sometimes pedal doesn't work first time

Alright guys! Thanks for the feedback! Hope I get a chance to work on it this weekend. Weather is supposed to warm up and dry up...
scooper77515 is offline   Reply With Quote
Unread 02-25-2015, 08:17 PM   #9
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,960
Default Re: 08 Precedent sometimes pedal doesn't work first time

Quote:
Originally Posted by jjance View Post
Tahoe, I often wondered about something. If you jumper the sw out before you turn the key switch on will you get a HPD. What I'm trying to say is turn the key sw on first and then jumper the MCOR switch.
No you won't. HPD doesn't happen unless throttle is applied. the two pin connector has nothing to do with applying throttle. It's simply a safety switch. The car won't run unless those two pins are connected. In fact, you'll notice no difference in operation with the jumper in place than you would with a perfectly good working mcor. The bad part is that if the throttle ever decided to fluctuate you would have a runaway Cart. That's why the two pin micro switch is still in use.
TahoeDawgZ71 is offline   Reply With Quote
Unread 02-27-2015, 04:49 PM   #10
Gone Wild
 
Join Date: Jun 2014
Posts: 365
Default Re: 08 Precedent sometimes pedal doesn't work first time

Coming late to the party, I concur on the MCOR. I have a cart right now that does the same thing. Sometimes you have to just slam the gas down a couple times and then it runs normally. It is a very intermittent problem, and the fix is pretty easy. It's just paying for the MCOR itself that sucks. I do them all the time
stang99x is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Precedent Gen1 pedal group with MCOR 3...how to make it work? Electric Club Car
07 precedent pedal problems? Electric Club Car
07 precedent pedal question Electric Club Car
Precedent Pedal Group Electric Club Car
precedent foot pedal Golf Carts and Parts


All times are GMT -5. The time now is 01:03 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.