lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-10-2015, 12:42 PM   #11
Gone Wild
 
oconnorb's Avatar
Club Car
 
Join Date: Aug 2011
Location: Va Beach, Virginia
Posts: 324
Default Re: Where did you install your controller?

No need to have worried, unbolt and new controller fits right in. Easy day, hope to get it finished today. Going from 300A to 500A, it is a 700A controller although I was advised by PQ to not exceed 500A due to distance traveled at higher speeds. With HD F/R, 400A (1000 peak) solenoid and 2ga cables from stock also upgraded, it should "drive" much better.
Attached Images
File Type: jpg image.jpg (370.4 KB, 0 views)
oconnorb is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-10-2015, 12:55 PM   #12
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,079
Default Re: Where did you install your controller?

Looking forward to reading the results!
scottyb is offline   Reply With Quote
Unread 03-10-2015, 04:22 PM   #13
Gone Wild
 
oconnorb's Avatar
Club Car
 
Join Date: Aug 2011
Location: Va Beach, Virginia
Posts: 324
Default Re: Where did you install your controller?

Well, forward goes forward and reverse is reverse, the charger is working.... Have to finish looming the speaker and misc item wires, then it is road test time. You can tell when the solenoid plunger pops, it is loud.
oconnorb is offline   Reply With Quote
Unread 03-10-2015, 04:24 PM   #14
ΜΟΛΩΝ ΛΑΒΕ
 
93yellowclubcar's Avatar
Club Car
 
Join Date: Nov 2012
Location: West Virginia
Posts: 4,094
Default Re: Where did you install your controller?

Isn't that honking big solenoid popping the coolest sound ever?
93yellowclubcar is offline   Reply With Quote
Unread 03-10-2015, 04:56 PM   #15
Gone Wild
 
oconnorb's Avatar
Club Car
 
Join Date: Aug 2011
Location: Va Beach, Virginia
Posts: 324
Default Re: Where did you install your controller?

Speed increase is marginal, although getting to street speed is faster, the missing torque from gear change is back. Speed was 34-35mph, as set up now, 38-39mph, which is plenty @ 500a.
oconnorb is offline   Reply With Quote
Unread 03-10-2015, 05:12 PM   #16
Gone Wild
 
Z71mtr's Avatar
 
Join Date: Oct 2013
Posts: 239
Default

Did you leave the factory settings the way they were on the controller?
Z71mtr is offline   Reply With Quote
Unread 03-10-2015, 06:22 PM   #17
Gone Wild
 
oconnorb's Avatar
Club Car
 
Join Date: Aug 2011
Location: Va Beach, Virginia
Posts: 324
Default Re: Where did you install your controller?

Nope, dialed down to 500a as per PQ for my motor.
oconnorb is offline   Reply With Quote
Unread 03-10-2015, 06:52 PM   #18
Gone Wild
 
Z71mtr's Avatar
 
Join Date: Oct 2013
Posts: 239
Default

How do you know how many amps it puts out by turning the dial
Z71mtr is offline   Reply With Quote
Unread 03-10-2015, 06:56 PM   #19
Gone Wild
 
Z71mtr's Avatar
 
Join Date: Oct 2013
Posts: 239
Default

I have mine set from factory settings because I did not feel anything when I turn the knob to know what setting I was at
Z71mtr is offline   Reply With Quote
Unread 03-10-2015, 10:21 PM   #20
Gone Wild
 
oconnorb's Avatar
Club Car
 
Join Date: Aug 2011
Location: Va Beach, Virginia
Posts: 324
Default Re: Where did you install your controller?

I didn't set the limit, I am not that bright, I contacted my ET buddy who builds components @ the shipyard, he contacted FSIP and discussed the "how to" IRT the current limiter setting. He brought over his mini screwdriver set and meters and dialed in the setting. IAW his conversation w/ customer service, it is set to a CL % that equates to 500 amps.

Otherwise, I am a "plug and play" installer, heck ScottyB had to almost draw me a picture to figure on the 5k-0k validation process. The cart runs well, motor temp is still below 98 degrees after almost an hour of running. Going to allow charger to complete full cycle and take out tomorrow to see how far DS will ride before below limits.

oconnorb is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Install 400-500 controller? Electric Club Car
05 txt pds controller install Electric EZGO
What to do with Run/Tow Switch after controller install Electric EZGO
Controller Install Electric EZGO
new controller install ?????????? Electric EZGO


All times are GMT -5. The time now is 08:02 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.