lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-04-2015, 08:27 PM   #41
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 4,581
Default Re: 05 club car wont run

How low does the pack voltage get while the wheels turn?

Make sure the motor field wires are seated properly on the controller.
Sergio is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-04-2015, 08:37 PM   #42
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 4,581
Default Re: 05 club car wont run

Quote:
Originally Posted by Geauxtigers View Post
Nope
Just put new solenoid on today and it would turn the wheels and then the solenoid would drop out
Then I had the short between the two terminals on the coil
Now I only have about 3v between two terminals on coil, press petal still 3v

Still have 50 volt on each coil terminal to b-
One of these readings is not right, if you measure from pack positive to controller side of the solenoid coil, you should get 0v with solenoid disengaged and 48v if the controller engages the solenoid.
Sergio is offline   Reply With Quote
Unread 03-04-2015, 08:38 PM   #43
Getting Wild
 
Geauxtigers's Avatar
Club Car
 
Join Date: Mar 2015
Location: Southwest louisiana
Posts: 106
Default Re: 05 club car wont run

Quote:
Originally Posted by Sergio View Post
How low does the pack voltage get while the wheels turn?

Make sure the motor field wires are seated properly on the controller.
About 49v
Geauxtigers is offline   Reply With Quote
Unread 03-04-2015, 08:39 PM   #44
Getting Wild
 
Geauxtigers's Avatar
Club Car
 
Join Date: Mar 2015
Location: Southwest louisiana
Posts: 106
Default Re: 05 club car wont run

Quote:
Originally Posted by Sergio View Post
One of these readings is not right, if you measure from pack positive to controller side of the solenoid coil, you should get 0v with solenoid disengaged and 48v if the controller engages the solenoid.
I was going from pack negative to both
Let me go try to pack positive
Geauxtigers is offline   Reply With Quote
Unread 03-04-2015, 08:54 PM   #45
Getting Wild
 
Geauxtigers's Avatar
Club Car
 
Join Date: Mar 2015
Location: Southwest louisiana
Posts: 106
Default Re: 05 club car wont run

Quote:
Originally Posted by Sergio View Post
One of these readings is not right, if you measure from pack positive to controller side of the solenoid coil, you should get 0v with solenoid disengaged and 48v if the controller engages the solenoid.
pack pos to blue/white...3.2 engaged 3.2
pack pos to light blue 0v engaged 0v

pack neg to blue/white...50 engaged 50
pack neg to light blue 50 engaged 50

engaged i mean petal down and in forward

solenoid not closing when petal down
Geauxtigers is offline   Reply With Quote
Unread 03-04-2015, 09:13 PM   #46
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 4,581
Default Re: 05 club car wont run

The controller circuit is not working anymore.

The only 2 valid measurements are:
  • Pack Negative to positive side of solenoid coil (light blue): Always +48v
  • Pack Positive to negative side of solenoid coil (blue/white): 0v Pedal Up and +48v pedal down.

All other measurements don't mean anything.

Sorry, but it looks like shorting the 2 small solenoid wires did short the controller activation transistor.
Sergio is offline   Reply With Quote
Unread 03-04-2015, 09:16 PM   #47
Getting Wild
 
Geauxtigers's Avatar
Club Car
 
Join Date: Mar 2015
Location: Southwest louisiana
Posts: 106
Default Re: 05 club car wont run

Quote:
Originally Posted by Sergio View Post
The controller circuit is not working anymore.

The only 2 valid measurements are:
  • Pack Negative to positive side of solenoid coil (light blue): Always +48v
  • Pack Positive to negative side of solenoid coil (blue/white): 0v Pedal Up and +48v pedal down.

All other measurements don't mean anything.

Sorry, but it looks like shorting the 2 small solenoid wires did short the controller activation transistor.
so buy whole new controller??
Geauxtigers is offline   Reply With Quote
Unread 03-04-2015, 09:20 PM   #48
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,883
Default Re: 05 club car wont run

Quote:
Originally Posted by Geauxtigers View Post
so buy whole new controller??
It will probably need to be replaced. But don't fry the new one! It's always a good idea to put the cart in Tow mode and disconnect the battery cable when working on the cart, then reconnect and flip to run to test.
There is a member selling an IQ controller and solenoid for $100. It's what you need...
jakesnake27 is offline   Reply With Quote
Unread 03-04-2015, 09:30 PM   #49
Getting Wild
 
Geauxtigers's Avatar
Club Car
 
Join Date: Mar 2015
Location: Southwest louisiana
Posts: 106
Default Re: 05 club car wont run

Quote:
Originally Posted by jakesnake27 View Post
It will probably need to be replaced. But don't fry the new one! It's always a good idea to put the cart in Tow mode and disconnect the battery cable when working on the cart, then reconnect and flip to run to test.
There is a member selling an IQ controller and solenoid for $100. It's what you need...
ill try not to....lol
i was just trying to test to see what was wrong while everything was hot!!!!
the dang tester lead just slipped and touch the other terminal!!!
just my luck!!!
im just glad someone gave it to me and didnt buy it!!
ill check the guy out selling the controller on here!!!
thanks again
Geauxtigers is offline   Reply With Quote
Unread 03-04-2015, 09:31 PM   #50
DS Drivers Club Founder
 
CCFanatic's Avatar
Club Car
 
Join Date: Jul 2013
Location: Upstate NY
Posts: 3,408
Default Re: 05 club car wont run

Quote:
Originally Posted by Geauxtigers View Post
ill try not to....lol
i was just trying to test to see what was wrong while everything was hot!!!!
the dang tester lead just slipped and touch the other terminal!!!
just my luck!!!
im just glad someone gave it to me and didnt buy it!!
ill check the guy out selling the controller on here!!!
thanks again
I have a set of clip leads so I don't have that kind of issue
CCFanatic is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
club car wont run Electric Club Car
85 club car wont do anything! Electric Club Car
86 club car wont go Electric Club Car
91 club car wont go Electric Club Car
96 club car wont go... Electric Club Car


All times are GMT -5. The time now is 04:06 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.