lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-09-2015, 10:05 AM   #21
Not Yet Wild
 
Join Date: Mar 2015
Posts: 21
Default Re: Club Car runs a bit then stops

Quote:
Originally Posted by weewilly View Post
Opp's. Just going through the reset thing and reading the part about the peeper. We did a major cleaning of the cart after we got it. We bagged the electrical stuff and pressure washed the unit off. Since then the Back up alarm has never worked...during cleaning it came on....we blew the unit off with a leaf blower unit it was dry. I'm thinking this is Bad. In the 5 minute mode right now and no beeper came on.
Thought we had it. Did the reset thing and fired up the charger, climbed to 46.2 then shut down and the amber light came on. Any suggestions were I go from here?
weewilly is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-09-2015, 11:56 AM   #22
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,895
Default Re: Club Car runs a bit then stops

Quote:
Originally Posted by weewilly View Post
Thought we had it. Did the reset thing and fired up the charger, climbed to 46.2 then shut down and the amber light came on. Any suggestions were I go from here?
I would say either bad OBC or charger at this point. Find a known working 48v CC and plug your charger into it. If it works, your OBC is most likely shot.
jakesnake27 is offline   Reply With Quote
Unread 03-09-2015, 01:18 PM   #23
Not Yet Wild
 
Join Date: Mar 2015
Posts: 21
Default Re: Club Car runs a bit then stops

Quote:
Originally Posted by jakesnake27 View Post
I would say either bad OBC or charger at this point. Find a known working 48v CC and plug your charger into it. If it works, your OBC is most likely shot.
So, the charger worked until I got up to 46.2 volts then shut off and the amber light came on. I just took the cart out for a spin, it lasted about 3 minutes and started to die out. Hooked up the charger and it is charging now. I expect shortly it will turn off and the amber light will come on before a full charge. If I plug it into my neighbours cart how will I be able to tell if it is working properly? If the charger is bad will his amber light come on? Thanx.
weewilly is offline   Reply With Quote
Unread 03-09-2015, 02:16 PM   #24
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,895
Default Re: Club Car runs a bit then stops

Quote:
Originally Posted by weewilly View Post
So, the charger worked until I got up to 46.2 volts then shut off and the amber light came on. I just took the cart out for a spin, it lasted about 3 minutes and started to die out. Hooked up the charger and it is charging now. I expect shortly it will turn off and the amber light will come on before a full charge. If I plug it into my neighbours cart how will I be able to tell if it is working properly? If the charger is bad will his amber light come on? Thanx.
Yes, the amber light should come on if the charger has an issue, indicating an abnormal charge cycle.
jakesnake27 is offline   Reply With Quote
Unread 03-10-2015, 11:35 AM   #25
Not Yet Wild
 
Join Date: Mar 2015
Posts: 21
Default Re: Club Car runs a bit then stops

Quote:
Originally Posted by jakesnake27 View Post
Yes, the amber light should come on if the charger has an issue, indicating an abnormal charge cycle.
Update, my charger has been on all night and is still doing the hum thing and no amber light. Batteries are at 46.5 and not climbing. Charger was humming and warm this morning and is now humming but not warm. I now have my neighbours charger, it is a power drive 3. Can I hurt his charger by trying it on my cart? Thanx.
weewilly is offline   Reply With Quote
Unread 03-10-2015, 11:50 AM   #26
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,895
Default Re: Club Car runs a bit then stops

Quote:
Originally Posted by weewilly View Post
Update, my charger has been on all night and is still doing the hum thing and no amber light. Batteries are at 46.5 and not climbing. Charger was humming and warm this morning and is now humming but not warm. I now have my neighbours charger, it is a power drive 3. Can I hurt his charger by trying it on my cart? Thanx.
No you won't hurt his charger, go ahead and try it.
jakesnake27 is offline   Reply With Quote
Unread 03-10-2015, 12:57 PM   #27
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,081
Default Re: Club Car runs a bit then stops

I might be late to this party - have you checked voltage on individual batteries to see if you have a bad one?
scottyb is offline   Reply With Quote
Unread 03-10-2015, 02:42 PM   #28
Not Yet Wild
 
Join Date: Mar 2015
Posts: 21
Default Re: Club Car runs a bit then stops

Quote:
Originally Posted by scottyb View Post
I might be late to this party - have you checked voltage on individual batteries to see if you have a bad one?
Any input is very much appreciated. The batteries are all around 7.5, not climbing through 46.5 with the new charger. The Charger needle has not read anything since I plugged it in. No amber light on. The sides of the batteries are bulged a bit.....in Canada that is a bad thing (battery likely froze at some point)....not sure about Florida...batteries are 2 years old and never left Florida, to my knowledge. Thanx.
weewilly is offline   Reply With Quote
Unread 03-10-2015, 02:52 PM   #29
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,895
Default Re: Club Car runs a bit then stops

Your batteries are certainly discharged. Are you using the new charger now?
jakesnake27 is offline   Reply With Quote
Unread 03-10-2015, 03:06 PM   #30
Not Yet Wild
 
Join Date: Mar 2015
Posts: 21
Default Re: Club Car runs a bit then stops

Quote:
Originally Posted by jakesnake27 View Post
Your batteries are certainly discharged. Are you using the new charger now?
yes
weewilly is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
GAS club car runs stops and run then fine Gas Club Car
G16 Starts, Runs for 6-8 minutes, Stops Gas Yamaha
Runs slow about 5 feet then stops Electric EZGO
G16 stops after 20 min, rests then runs fine Gas Yamaha
Runs then just stops Electric Club Car


All times are GMT -5. The time now is 03:21 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.