lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-30-2015, 04:42 PM   #11
STEALTH 4X4
 
sunoco's Avatar
Club Car
 
Join Date: Sep 2011
Location: GA
Posts: 2,017
Default Re: 05 rebuild problem

Ok so do what CCfanatic said and jump the 2 wire plug on the MCOR with a paper clip, with the rear end jacked up

"2. I let batteries get down a little on purpose just to see if that's the problem" - batteries should never be ran below 50%
sunoco is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-30-2015, 04:47 PM   #12
STEALTH 4X4
 
sunoco's Avatar
Club Car
 
Join Date: Sep 2011
Location: GA
Posts: 2,017
Default Re: 05 rebuild problem

I suspect your pedal has worn and can't give the accelerator pivot barll range of motion to turn the mcor.

Use the file that gives you the highest throttle postion.
Remove the mcor from the cart and actuate it by hand (with the rear jacked up of course) to see if you get to 100%. If so, replace the go pedal. The aluminum gets worn over time and will "divot" out, causing the MCOR not to get the full turn from the pivot bar.
sunoco is offline   Reply With Quote
Unread 03-30-2015, 05:00 PM   #13
Getting Wild
 
Geauxtigers's Avatar
Club Car
 
Join Date: Mar 2015
Location: Southwest louisiana
Posts: 106
Default Re: 05 rebuild problem

Files
Attached Images
File Type: jpg image.jpg (139.2 KB, 0 views)
Geauxtigers is offline   Reply With Quote
Unread 03-30-2015, 05:11 PM   #14
Getting Wild
 
Geauxtigers's Avatar
Club Car
 
Join Date: Mar 2015
Location: Southwest louisiana
Posts: 106
Default Re: 05 rebuild problem

Quote:
Originally Posted by sunoco View Post
Ok so do what CCfanatic said and jump the 2 wire plug on the MCOR with a paper clip, with the rear end jacked up

"2. I let batteries get down a little on purpose just to see if that's the problem" - batteries should never be ran below 50%
1. will do
2. probably need new batteries
Geauxtigers is offline   Reply With Quote
Unread 03-30-2015, 05:34 PM   #15
Getting Wild
 
Geauxtigers's Avatar
Club Car
 
Join Date: Mar 2015
Location: Southwest louisiana
Posts: 106
Default Re: 05 rebuild problem

Never shut off yet with wheels off ground
This is with the throttle set on club car!!
Attached Images
File Type: jpg image.jpg (239.6 KB, 0 views)
Geauxtigers is offline   Reply With Quote
Unread 03-30-2015, 05:34 PM   #16
Getting Wild
 
Geauxtigers's Avatar
Club Car
 
Join Date: Mar 2015
Location: Southwest louisiana
Posts: 106
Default Re: 05 rebuild problem

Setting on ezgo
Attached Images
File Type: jpg image.jpg (169.3 KB, 0 views)
Geauxtigers is offline   Reply With Quote
Unread 03-30-2015, 05:36 PM   #17
Getting Wild
 
Geauxtigers's Avatar
Club Car
 
Join Date: Mar 2015
Location: Southwest louisiana
Posts: 106
Default Re: 05 rebuild problem

mcor good.....batteries bad???
Geauxtigers is offline   Reply With Quote
Unread 03-30-2015, 06:19 PM   #18
STEALTH 4X4
 
sunoco's Avatar
Club Car
 
Join Date: Sep 2011
Location: GA
Posts: 2,017
Default Re: 05 rebuild problem

Is that from you doing the paperclip test?
sunoco is offline   Reply With Quote
Unread 03-30-2015, 06:24 PM   #19
Getting Wild
 
Geauxtigers's Avatar
Club Car
 
Join Date: Mar 2015
Location: Southwest louisiana
Posts: 106
Default Re: 05 rebuild problem

Quote:
Originally Posted by sunoco View Post
Is that from you doing the paperclip test?
No
it never cut off with wheels off ground, and I got it to full throttle 20-30 times in a row

Guessing I need new batteries and maybe upgraded
wires???
Geauxtigers is offline   Reply With Quote
Unread 03-30-2015, 09:48 PM   #20
Getting Wild
 
Geauxtigers's Avatar
Club Car
 
Join Date: Mar 2015
Location: Southwest louisiana
Posts: 106
Default Re: 05 rebuild problem

Bump
Geauxtigers is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
cart rebuild charger problem!!! Electric Club Car
G9 motor rebuild problem Gas Yamaha
fresh rebuild problem Gas EZGO
motor rebuild problem Gas EZGO
Problem with rebuild Gas Yamaha


All times are GMT -5. The time now is 05:14 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.