lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-10-2015, 09:39 PM   #1
Not Yet Wild
 
Join Date: Apr 2014
Posts: 72
Unhappy I smoked something

I have a 2006 cc ds iq , w/23" tires,6" jakes lift, 48v sepex,400amp.alltrex w/hd solenoid, a plum qiick bandit rebuild less than 60 days old. I went shroom hunting today, well got stuck in the mud, it was bad, motor got hot. It lost power to spin tires, so icalled for a tow, got it back to the road and it semed fine, had about a mile to get home on the road, when I went up inclines it would sometimes jump like my foot would slip of pedal. When i pulled into my driveway it quit totally and red light on the controler was flashing w/some smoke coming from controller! I put it in tow quickly allowed it to cool down, when I put it back in run, the reverse buzzer would ring in forward and reverse, would not move either direction! Solenoid still clicked properly!
I'm sure I burned something up! Question is what (controller or motor or both).
Where do I start????
thanks in advance for all input, this one may be for the big boys

bartman357
Bartman357 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-10-2015, 09:47 PM   #2
ΜΟΛΩΝ ΛΑΒΕ
 
93yellowclubcar's Avatar
Club Car
 
Join Date: Nov 2012
Location: West Virginia
Posts: 4,094
Default Re: I smoked something

Quote:
Originally Posted by Bartman357 View Post
I have a 2006 cc ds iq , w/23" tires,6" jakes lift, 48v sepex,400amp.alltrex w/hd solenoid, a plum qiick bandit rebuild less than 60 days old. I went shroom hunting today, well got stuck in the mud, it was bad, motor got hot. It lost power to spin tires, so icalled for a tow, got it back to the road and it semed fine, had about a mile to get home on the road, when I went up inclines it would sometimes jump like my foot would slip of pedal. When i pulled into my driveway it quit totally and red light on the controler was flashing w/some smoke coming from controller! I put it in tow quickly allowed it to cool down, when I put it back in run, the reverse buzzer would ring in forward and reverse, would not move either direction! Solenoid still clicked properly!
I'm sure I burned something up! Question is what (controller or motor or both).
Where do I start????
thanks in advance for all input, this one may be for the big boys

bartman357
Title: I smoked something

Within first two sentences: shroom hunting


I think I see where this one's headed...



In all seriousness, I think you might have released the magic smoke from the controller. Once released, this smoke cannot be put back in unfortunately.
93yellowclubcar is offline   Reply With Quote
Unread 04-10-2015, 10:17 PM   #3
Not Yet Wild
 
Join Date: Apr 2014
Posts: 72
Default Re: I smoked something

Yellow I guess I didn't pick my words very well! Where should I start?
Bartman357 is offline   Reply With Quote
Unread 04-10-2015, 10:44 PM   #4
ΜΟΛΩΝ ΛΑΒΕ
 
93yellowclubcar's Avatar
Club Car
 
Join Date: Nov 2012
Location: West Virginia
Posts: 4,094
Default Re: I smoked something

Since you saw smoke from the controller, I'd say start with a new one unfortunately. Someone with more controller mishap experience might be able to give more advice when they come along, I only ever blew up one controller myself, and it was VERY obvious when it happened. Blew the end right out of a 275 amp Curtis! It made a nice loud "POP" and there was plenty of nasty smelling smoke.

When you got towed, did you by chance have it in the run position?
93yellowclubcar is offline   Reply With Quote
Unread 04-10-2015, 10:48 PM   #5
Let's go racin' boyz!!
 
TerryH's Avatar
E-Z-GO
 
Join Date: Oct 2010
Location: Springdale, AR
Posts: 4,155
Default Re: I smoked something

Quote:
Originally Posted by 93yellowclubcar View Post
Title: I smoked something

Within first two sentences: shroom hunting


I think I see where this one's headed... .
I was going to say something but I can't remember what it was.
TerryH is offline   Reply With Quote
Unread 04-10-2015, 11:57 PM   #6
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,095
Default Re: I smoked something

UNfortunately I think your problem is two fold. When the motor goes bad as you have described it loosing power then surging you have a 50/50 chance of smoking the controller.
scottyb is offline   Reply With Quote
Unread 04-10-2015, 11:58 PM   #7
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,095
Default Re: I smoked something

I had a customer do that twice with a similar set up in an Ezgo
scottyb is offline   Reply With Quote
Unread 04-11-2015, 08:13 AM   #8
Not Yet Wild
 
Join Date: Apr 2014
Posts: 72
Default Re: I smoked something

Scotty, do you then that the controller is the place to start? Is there a way to test it? Or would it better to start with the motor? Probably should get a bigger controller anyway!
I read that my sepex motor may not be big enough anyway! Give me a couple ideas to try and I may be giving you a call!
Bartman357 is offline   Reply With Quote
Unread 04-11-2015, 10:22 AM   #9
Gone Wild
 
DJBlade's Avatar
Club Car
 
Join Date: Dec 2011
Location: Columbia, South Carolina
Posts: 258
Default Re: I smoked something

I would test the motor first. Last thing you want is a bad motor taking out a new controller.
DJBlade is offline   Reply With Quote
Unread 04-11-2015, 10:25 AM   #10
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,095
Default Re: I smoked something

Quote:
Originally Posted by DJBlade View Post
I would test the motor first. Last thing you want is a bad motor taking out a new controller.
Usually you can remove the motor and smell the unmistakable burnt electrical smell.... then you know it's the cause. In which case I would upgrade both motor and control. Shoot me an email about this and I'll let you know what I can do for you with this.
scottyb is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
smoked wire Electric EZGO
smoked wire Electric EZGO
f/r switch smoked Electric EZGO
Smoked VGlide Electric Club Car
smoked Electric Club Car


All times are GMT -5. The time now is 01:44 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.