lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-13-2015, 07:50 PM   #1
Gone Wild
 
mike_dmt's Avatar
 
Join Date: Jul 2014
Posts: 292
Default Gahh... Another electrical problem....

Ok, thought I had it figured out, but...


I got my microswitches squared away, but now I have TWO issues.

1st: The solenoid I ordered ended up being physically smaller, and had a 12v sticker on it. As I was driving down the block, I could smell something... Sure enough the replacement was just about boiling... So, that needs replaced with the correct one.

THEN, 2nd problem: I turned around and lost ALL power... Got the cart home to discover a yellow/black wire from the switch block was broken off from somewhere. I have no idea where it goes.
mike_dmt is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-13-2015, 08:36 PM   #2
Gone Wild
 
scooterman's Avatar
Club Car
 
Join Date: Jan 2014
Location: Lafayette, Louisiana
Posts: 1,641
Default Re: Gahh... Another electrical problem....

Why did you install a 12v solenoid knowing well it wasn't going to work, that can cause a fire?
scooterman is offline   Reply With Quote
Unread 04-13-2015, 08:54 PM   #3
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,883
Default Re: Gahh... Another electrical problem....

Do you have the correct solenoid in now?

It's a simple drive system, easy to diagnose too...
jakesnake27 is offline   Reply With Quote
Unread 04-14-2015, 12:57 PM   #4
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: Gahh... Another electrical problem....

Where are you getting your parts from? First bad micro sw then wrong solenoid.
jjance is offline   Reply With Quote
Unread 04-14-2015, 01:06 PM   #5
Gone Wild
 
mike_dmt's Avatar
 
Join Date: Jul 2014
Posts: 292
Default Re: Gahh... Another electrical problem....

.... Simple mistake. The bus bar was touching the small terminals on the first solenoid. Thanks guys.
mike_dmt is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
New Electrical Problem Electric EZGO
Otm electrical problem Electric Club Car
EZ-Go electrical problem Electric EZGO
Electrical Problem Electric Club Car


All times are GMT -5. The time now is 10:15 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.