lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-27-2015, 12:51 AM   #1
Not Yet Wild
 
Join Date: Nov 2010
Posts: 8
Default 2010 precedent stops running at speed

I have a precedent w 2 yr old batteries sc4 and for no reason at all, power goes away. Step on the go pedal and nothing for about 5 minutes. Solenoid clicks on and off. Rev buzzer works, Initially will go for a second and kick out again. Wait some more and she'll run again for a few minutes and shut down again.
HPD code on iqdm. not sure if that has anything to do with this issue.
Checked all the electrical contacts and tightened them

Help! Anyone have any ideas??!

Thank you in advance
muspod is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-27-2015, 08:01 AM   #2
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,354
Default Re: 2010 precedent stops running at speed

It sounds like a bad MCOR to me. Open the MONITOR menu of the IQDM and watch the "Foot Input" and see if it's turning on every time you depress the pedal. If it's staying off, replace the MCOR.
TahoeDawgZ71 is offline   Reply With Quote
Unread 04-27-2015, 09:57 PM   #3
Not Yet Wild
 
Join Date: Nov 2010
Posts: 8
Default Re: 2010 precedent stops running at speed

new MCOR installed and problem solved. Thank you!!
Can they be repaired anywhere?
muspod is offline   Reply With Quote
Unread 04-27-2015, 10:02 PM   #4
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,134
Default Re: 2010 precedent stops running at speed

A few members have opened them up, but they are kinda made to be throw always when they go out...

See this thread: Inside An MCOR 01-04 DS
jakesnake27 is offline   Reply With Quote
Unread 04-27-2015, 10:05 PM   #5
Voltaholic
 
Revolution's Avatar
Mixed Breed
 
Join Date: Dec 2013
Location: Close to Navasota Texas
Posts: 933
Default Re: 2010 precedent stops running at speed

2 post and problem solved! Is that some kind or record? Too bad they can't all be that easy.
Revolution is offline   Reply With Quote
Unread 09-07-2016, 07:41 AM   #6
Not Yet Wild
 
Join Date: Sep 2016
Posts: 1
Question Re: 2010 precedent stops running at speed

Which model of MCOR was the new one MCOR 3 or MCOR 4
Ygaud is offline   Reply With Quote
Unread 09-07-2016, 07:55 AM   #7
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,354
Default Re: 2010 precedent stops running at speed

MCOR4 is the new replacement. The MCOR3 is no longer available.
TahoeDawgZ71 is offline   Reply With Quote
Unread 09-07-2016, 08:36 AM   #8
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 61,820
Default Re: 2010 precedent stops running at speed

2 posts and solved because the MCOR problem with CC is so well documented Hilary Clinton could answer the question.
Look at the number of MCOR related complaints in this section. I put MCOR into the search bar and 1580 threads come up - sheesh.
scottyb is offline   Reply With Quote
Unread 09-07-2016, 08:45 AM   #9
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,134
Default Re: 2010 precedent stops running at speed

It is kinda crazy isn't it Scotty? I guess I've been lucky, my '02 has the original MCOR and has never given me any problems (knocking on wood now).

Quick question, does the XCT controller alleviate MCOR problems (compared to the stock controller)?
jakesnake27 is offline   Reply With Quote
Unread 09-07-2016, 09:38 AM   #10
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 61,820
Default Re: 2010 precedent stops running at speed

The XCT can be pre-set to read any % range as 0-100% or to read the cart's real range (whatever it is) and establish that as the normal 0-100% but the key word is establish. If the signal is erratic or changing each time you press the go pedal as I read the MCOR can, then the XCT can not compensate for that. That would be like me making up new words each sentence and expecting you to understand my message.
I had to change out the MCOR in my 05 test cart. When I ran the old DCX I used an inline resistor to correct the signal to a true 0-5k. Now with the XCT that inline gizmo is removed and the new control has established the 1-6k(ish) signal as 0-100% & the cart response is smoother than it ever was.
scottyb is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2010 club car precedent stops and goes Electric Club Car
2010 Precedent half speed Electric Club Car
2010 Precedent - Best way for more speed Electric Club Car
2010 Precedent Speed Upgrade Electric Club Car
2010 Precedent top speed Electric Club Car


All times are GMT -5. The time now is 11:50 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.