lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-09-2015, 12:18 PM   #1
Gone Wild
 
Fishing Dude's Avatar
Club Car
 
Join Date: Jul 2008
Location: Slums of Lake Erie
Posts: 3,722
Default 97 regen

Ok need some help think I might know but not sure.

It will not move and the solenoid clicks, last it moved under own power had to help to get it to move on own power first time then ran fine. Had this happening for awhile.
Fishing Dude is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-09-2015, 09:10 PM   #2
Epb
Gone Wild
Club Car
 
Join Date: Mar 2012
Location: Katy, Tx
Posts: 1,019
Default Re: 97 regen

Brushes in motor bad?
Epb is offline   Reply With Quote
Unread 05-10-2015, 11:35 AM   #3
Gone Wild
 
Fishing Dude's Avatar
Club Car
 
Join Date: Jul 2008
Location: Slums of Lake Erie
Posts: 3,722
Default Re: 97 regen

Quote:
Originally Posted by Epb View Post
Brushes in motor bad?
wondering that too, but motor has low hrs. Thinking controller
Fishing Dude is offline   Reply With Quote
Unread 05-10-2015, 02:52 PM   #4
Epb
Gone Wild
Club Car
 
Join Date: Mar 2012
Location: Katy, Tx
Posts: 1,019
Default Re: 97 regen

I think a controller failure would be just that. When u pushed it to go led me to believe the brushes. I did this once and helped the motor and it started to turn. I emery clothed them and it was all good. Maybe this is just my fluke experience. It won't hurt to check. Let's see what others say
Epb is offline   Reply With Quote
Unread 05-13-2015, 10:31 PM   #5
Not Yet Wild
Club Car
 
Join Date: Feb 2015
Location: Big Lake TX
Posts: 66
Default Re: 97 regen

I had a similar issue with my 97. Ended up being the v glide. If yours has one check the resistors and make sure the wiper arm is making good contact with the platest.
MarioD. is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Regen 1 / Regen 2 soleniod question Electric Club Car
Regen 1 to regen 2 conversion Electric Club Car
To convert a regen cart to a non regen cart? Electric Club Car
97 regen cart...I HATE REGEN BRAKING!! Electric Club Car
What is Regen Electric Club Car


All times are GMT -5. The time now is 04:08 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.