lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-18-2015, 11:06 AM   #1
Not Yet Wild
 
Join Date: Sep 2008
Posts: 59
Default 06 Precedent - Full Charge, but silent

This has happened twice in the last 3 years, and I' have a buyer for it, so will upgrade, but if it does not work no sale...
Pull a full charge on it....Disconnected charger, let it sit for 4 hours, Went to drive it ...batter voltage read 50.2 volts, engaged reverse.. depressed the pedal...NOTHING ...Turned key on OFF ..NOTHING ..... Put the cart in TOW rocked it back and forth.. NOTHING./..Then just held the pedal down in reverse and after 10 second the cart started to move slowly then BOOM ran normally.
Put it in Forward...NOTHING .. reverse still OK ..Back to forward and after 15 seconds with the pedal to the floor.. BOOM ran fine and all is normal...

The last time it did this ..was in the yard , stopped got off, turned key off...1 minute later..NO go ...and after playing with the pedal it began to move..

Idea's so I can reimburse the new owner for repairs..

Bill
Bill In Georgia is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-18-2015, 11:16 AM   #2
Gone Wild
Club Car
 
Join Date: Jan 2014
Location: Okatie, SC
Posts: 309
Default Re: 06 Precedent - Full Charge, but silent

Sounds like a MCOR issue (speed/throttle control). Check the STICKYS for repair info.
Hecky50 is offline   Reply With Quote
Unread 05-18-2015, 04:24 PM   #3
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,981
Default Re: 06 Precedent - Full Charge, but silent

I agree. Definitely sounds like an mcor issue.
TahoeDawgZ71 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Why only 37.5V at full charge?? Electric EZGO
How far on full charge have you gone? Electric Club Car
Not getting full charge Electric Club Car
Full charge. Won't Go. Electric Club Car
Not getting a full charge Electric Club Car


All times are GMT -5. The time now is 01:54 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.