lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-11-2015, 11:09 PM   #1
Not Yet Wild
Club Car
 
Join Date: Jul 2011
Location: Houston Texas
Posts: 9
Default Another charger question

I have a power drive 22110 charger, Everything has been working. I replace the batteries about a month ago. Plugged the charger in this weekend and nothing happen. The amp meter didn't move , the transformer hummed for just a second and tripped the breaker on the charger.Reset the breaker it tripped again. Disconnect the power to the charger and plugged the charger into the cart and the relay clicked in the charger. I have replace rectifier . Is there away to test the charger with out the golf cart ? I am back home now and the cart is in the country. Could I still have a problem with the relay , I have jumper the two small wires on the relay and nothing happen.

Thanks
earl b is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-11-2015, 11:47 PM   #2
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,966
Default Re: Another charger question

When did you replace the rectifier?
TahoeDawgZ71 is offline   Reply With Quote
Unread 06-12-2015, 07:33 AM   #3
Not Yet Wild
Club Car
 
Join Date: Jul 2011
Location: Houston Texas
Posts: 9
Default Re: Another charger question

Yes I replaced the rectifier.
earl b is offline   Reply With Quote
Unread 06-12-2015, 08:24 AM   #4
Not Yet Wild
Club Car
 
Join Date: Jul 2011
Location: Houston Texas
Posts: 9
Default Re: Another charger question

I have 110v from the breaker to black wire on the right side of the 855aw-f-c1 relay but not leaving the relay going to the transformer.
earl b is offline   Reply With Quote
Unread 06-12-2015, 02:35 PM   #5
Not Yet Wild
Club Car
 
Join Date: Jul 2011
Location: Houston Texas
Posts: 9
Default Re: Another charger question

Found problem the switch was also bad. Replaced and charger is working. It would click when plugged in but wasn't changing state.

thanks
earl b is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Charger Question Electric EZGO
Charger Question Electric EZGO
Charger Question Electric Club Car
Charger Question Electric EZGO
charger question Electric EZGO


All times are GMT -5. The time now is 01:35 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.