lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-22-2015, 03:47 PM   #1
Not Yet Wild
 
Join Date: Nov 2010
Posts: 38
Default need help. cart no go

2000 club car. my cart would travel good then slow down then stop completely. then go good for a while then go really really slow. batteries are good. selenoid maybe? and if so i dont know how to test. thanks for any help
mikerose is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-22-2015, 04:24 PM   #2
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 2,681
Default Re: need help. cart no go

You may say they are good but many problems like this are due to either a faulty battery or a bad connection. Measure all of your battery voltages. If it's not running, monitor the full pack voltage when you try and go.
Volt_Ampere is offline   Reply With Quote
Unread 06-22-2015, 04:29 PM   #3
Not Yet Wild
 
Join Date: Nov 2010
Posts: 38
Default Re: need help. cart no go

forgot to mention that it wont go reverse either. i measured the pack but not with the pedal down. it measured 49.2 just on its own. i didnt measure each battery but i will.
mikerose is offline   Reply With Quote
Unread 06-22-2015, 04:36 PM   #4
Not Yet Wild
Club Car
 
Join Date: Jun 2012
Location: College Station, TX
Posts: 28
Default Re: need help. cart no go

I believe 49.2 is ~65% of fully charged... You might have a battery or 2 that is on it's way out.
Record each battery's voltage(plus to minus) after a FULL charge and 12 hours rest and post them up here.
Drewfus is offline   Reply With Quote
Unread 06-23-2015, 04:54 PM   #5
Not Yet Wild
 
Join Date: Nov 2010
Posts: 38
Default Re: need help. cart no go

ok guys. i found one if the three microswitches behind the f/r swith had a broken connection. it is the first one of the three. so i connected the wires straight and push the pedal and it moves. could this little switch keep the cart from going. it seems so insignificant.
mikerose is offline   Reply With Quote
Unread 06-23-2015, 07:02 PM   #6
Gone Wild
Club Car
 
Join Date: Apr 2014
Location: Oregon City, Or
Posts: 1,939
Default Re: need help. cart no go

Quote:
Originally Posted by mikerose View Post
ok guys. i found one if the three microswitches behind the f/r swith had a broken connection. it is the first one of the three. so i connected the wires straight and push the pedal and it moves. could this little switch keep the cart from going. it seems so insignificant.
The short answer---Yes


.
tag50 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes



All times are GMT -5. The time now is 05:23 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.