lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-07-2008, 04:31 PM   #1
Gone Wild
 
cheapjeep2's Avatar
Club Car
 
Join Date: Nov 2008
Location: Peachtree City, Georgia
Posts: 1,529
Default Anyone running an Admiral Motor?

I purchased an Admiral Motor for my 01 Regen Club Car? Claims 9 peak hp. Any running one of these motors have any thoughts or feedback on it's performance?
cheapjeep2 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-08-2008, 07:42 PM   #2
Getting Wild
 
Join Date: Feb 2008
Posts: 75
Default Re: Anyone running an Admiral Motor?

The price is Good on them. Never tried them yet. Other motor dealers said they were cheap imports, but almost everything you buy is import. That 9 hp would be peak, so you could maybe says its 4hp normal use.
Carts Zone is offline   Reply With Quote
Unread 12-10-2008, 11:11 PM   #3
Gone Wild
 
cheapjeep2's Avatar
Club Car
 
Join Date: Nov 2008
Location: Peachtree City, Georgia
Posts: 1,529
Default Re: Anyone running an Admiral Motor?

Got my Admiral motor today. Looks to be well built with quality materials. I guess we'll see once it's installed. I'll reply back with a status of how it runs as I know there isn't much feed back for them on the forum.
cheapjeep2 is offline   Reply With Quote
Unread 12-29-2008, 10:16 PM   #4
Gone Wild
 
cheapjeep2's Avatar
Club Car
 
Join Date: Nov 2008
Location: Peachtree City, Georgia
Posts: 1,529
Default Re: Anyone running an Admiral Motor?

As promised I said I would update the forum. Got my Admiral motors installed and it all went well, this is a great motor for the money, lots of power and speed. I recommend it!
cheapjeep2 is offline   Reply With Quote
Unread 12-30-2008, 03:45 PM   #5
Gone Wild
 
cheapjeep2's Avatar
Club Car
 
Join Date: Nov 2008
Location: Peachtree City, Georgia
Posts: 1,529
Default Re: Anyone running an Admiral Motor?

Just got back from a about a 40 min. run around the area. Motor was flawless! I got it brand new from Ebay and paid $445 shipped.
Got it from this seller but there are others that sell the same motor. http://stores.ebay.com/superbargainbarn-4less
cheapjeep2 is offline   Reply With Quote
Unread 04-05-2010, 03:17 PM   #6
Getting Wild
 
flasharps's Avatar
Club Car
 
Join Date: Mar 2010
Location: Estero, Florida
Posts: 140
Default Re: Anyone running an Admiral Motor?

I installed my MOT-A1. Motor is great! Lots of power!

Question... It seems to have a whiny sound to it. Does yours do the same? Everything else is flawless, just the sound. Is this due to the fact it has more power?
flasharps is offline   Reply With Quote
Unread 04-05-2010, 03:22 PM   #7
Gone Wild
 
cheapjeep2's Avatar
Club Car
 
Join Date: Nov 2008
Location: Peachtree City, Georgia
Posts: 1,529
Default Re: Anyone running an Admiral Motor?

Quote:
Originally Posted by flasharps View Post
I installed my MOT-A1. Motor is great! Lots of power!

Question... It seems to have a whiny sound to it. Does yours do the same? Everything else is flawless, just the sound. Is this due to the fact it has more power?
funny you found my way old thread, no it doesn't have a whinny sound, at least not that I hear.
cheapjeep2 is offline   Reply With Quote
Unread 04-05-2010, 03:26 PM   #8
Getting Wild
 
flasharps's Avatar
Club Car
 
Join Date: Mar 2010
Location: Estero, Florida
Posts: 140
Default Re: Anyone running an Admiral Motor?

Quote:
Originally Posted by cheapjeep2 View Post
funny you found my way old thread, no it doesn't have a whinny sound, at least not that I hear.
:) Mine almost sounds like a bearing sound.
flasharps is offline   Reply With Quote
Unread 04-05-2010, 03:32 PM   #9
Getting Wild
 
flasharps's Avatar
Club Car
 
Join Date: Mar 2010
Location: Estero, Florida
Posts: 140
Default Re: Anyone running an Admiral Motor?

I just read that the motors might make a noise until the brushes set in.

Hopefully this will be true. It doesn't effect the performance at all.
flasharps is offline   Reply With Quote
Unread 04-07-2010, 08:49 PM   #10
Gone Wild
 
white rice's Avatar
Club Car
 
Join Date: Apr 2009
Location: Tifton, GA
Posts: 165
Default Re: Anyone running an Admiral Motor?

I have that 9hp motor on my 99 regen with a 500amp controller and it is crazy how much more power i got. About 25mph and loads of torque. Mine has that same little whine, i wouldnt worry about it.
white rice is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
85 g1 running good Gas Yamaha
Complete running '90 244 3PG FS Golf Carts and Parts
motor won't stay running Gas Yamaha
Admiral motor Electric Club Car
My cart running Videos


All times are GMT -5. The time now is 08:53 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.