lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-26-2015, 10:48 AM   #1
Not Yet Wild
Yamaha
 
Join Date: Jun 2011
Location: Danville, PA
Posts: 16
Default Club Car Precedent wont move

Okay I am lost on this issue. Here is a list of the following items that I have replaced and it still will not work. All I hear is clicking at the solenoid.

I have replaced the Solenoid
I have replaced the MCOR. Although I replaced the MCOR II with a I. will that matter
I have replaced the speed sensor.
I have a new resistor that is on the way and should be at home today when I get there.

Batteries are good, they charge like they should. I have read that it could be the OBC, but the charger would not work if the OBC was not working properly? Is this correct?

But all I keep hearing is the clicking of the solenoid. Checked all fuses and they are good. Tried the resetting of the OBC, still nothing.

I hooked directly up the the motor with 48v and the motor turned, so I believe the motor to be good.

Could it be something in the DC Motor controller.

Can I bypass the solenoid and see if it works? I have the solenoid hooked up with the positive to the batteries and the negative to the yellow cable which goes to the controller.

I have about had it with trying things, and they are costly. Is there someone close to Danville, PA on here that I could bring it to.
Micro86 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-26-2015, 04:41 PM   #2
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,977
Default Re: Club Car Precedent wont move

The MCOR1 won't fit on a Precedent. The mounting tabs are different and so is the input shaft. It has a star splined shaft for a DS car, the MCOR2 is for the Precedent only and uses one oval shaped input shaft.

The problem could be within the motor or the controller. It may also be the solenoid. Check to make sure power is getting across the solenoid when it clicks. Get a multimeter and put the large lead on the large yellow wire on the solenoid and the black lead on the main negative battery post. Once the solenoid clicks, you should see full battery voltage on your meter. If this checks out good, flip the tow switch and unhook the main negative and main positive battery posts. Remove all four wires from the electric motor. Check for continuity between A1 and A2. You should see no resistance. Check for continuity between F1 and F2. You should also see no resistance there. If the motor and solenoid both check out good, I'd say you're in the market for a controller if we can figure out exactly which MCOR you installed.
TahoeDawgZ71 is offline   Reply With Quote
Unread 06-26-2015, 05:00 PM   #3
Not Yet Wild
Yamaha
 
Join Date: Jun 2011
Location: Danville, PA
Posts: 16
Default Re: Club Car Precedent wont move

well I assumed it was an MCORI as the other one was labeled a II when I went to purchase it. It is identical to the one I took off so it must be ok. I will check what you said and reply back
Micro86 is offline   Reply With Quote
Unread 06-26-2015, 05:34 PM   #4
Not Yet Wild
Yamaha
 
Join Date: Jun 2011
Location: Danville, PA
Posts: 16
Default Re: Club Car Precedent wont move

Ok have voltage across the solenoid, check continuity between A1-A2 and F1-F2 have continuity across those terminals. Also read to check across A1-F1 and A2-F2 did not get any continuity. So I assume my motor is ok. Is there a way to test the DC Controller
Micro86 is offline   Reply With Quote
Unread 06-28-2015, 08:13 PM   #5
Not Yet Wild
Yamaha
 
Join Date: Jun 2011
Location: Danville, PA
Posts: 16
Default Re: Club Car Precedent wont move

Thanks for the information Tahoe, it turned out to be the DC Motor Controller. Now do you know where to get it rebuilt. I bought one of a local guy here and it was a remanufactured one. Figured I would try to get my old one down in the event I ever need it again.
Micro86 is offline   Reply With Quote
Unread 06-29-2015, 11:45 PM   #6
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,977
Default Re: Club Car Precedent wont move

Quote:
Originally Posted by Micro86 View Post
Thanks for the information Tahoe, it turned out to be the DC Motor Controller. Now do you know where to get it rebuilt. I bought one of a local guy here and it was a remanufactured one. Figured I would try to get my old one down in the event I ever need it again.
PM Sent
TahoeDawgZ71 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
03 club car 48v wont move.... Electric Club Car
2005 club car precedent wont move Electric Club Car
washed CC Precedent, now wont move Electric Club Car
club car wont move Electric Club Car
96 club car wont move Electric Club Car


All times are GMT -5. The time now is 03:55 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.