lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-03-2015, 06:47 PM   #11
Gone Wild
 
theboss20's Avatar
Harley Davidson
 
Join Date: Jun 2014
Location: Buckeye, Az
Posts: 646
Smile Re: 99 club car quit running and won't charge

Just had a similar problem with the wife's 97 CC DS series cart with F/R lever by your right leg. I had gone through this cart from A to Z so I was very disappointed when it started acting up. What I found was three micro-switches on the top of the F/R switch and the wires had corroded so badly that one wire broke off with the tab from the micro-switch still attached. You wouldn't think that could happen but it did and it stops the cart from moving...trust me...lol
theboss20 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-03-2015, 07:04 PM   #12
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 4,582
Default Re: 99 club car quit running and won't charge

The OBC controls both the solenoid negative lead and the charging circuit.

Since You are getting +48v at the solenoid, the circuit through key switch, limit switch and pedal switch is working fine.

The OBC is either dead, or it mat just be the fuse on those old carts.

Check the red wire coming off the OBC for the fuse and make sure it is good.

If so, You can run a jumper (16awg wire) from the small solenoid post where the yellow wire is connected directly to B- or pack negative (whichever is easier).

If the cart works fine, the OBC is bad.
Sergio is online now   Reply With Quote
Unread 07-03-2015, 11:36 PM   #13
Not Yet Wild
 
Join Date: Jul 2015
Posts: 12
Default Re: 99 club car quit running and won't charge

Thanks Sergio I'll try that tomorrow and see what happens, just happened to see your location I'm about a hour from Charlotte I'm close to hickory nc
Adam1greene is offline   Reply With Quote
Unread 07-04-2015, 10:30 AM   #14
Not Yet Wild
 
Join Date: Jul 2015
Posts: 12
Default Re: 99 club car quit running and won't charge

Sergio I just tried that and still nothing. So does that mean the obc is good and something else is bad?
Adam1greene is offline   Reply With Quote
Unread 07-04-2015, 11:13 AM   #15
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 4,582
Default Re: 99 club car quit running and won't charge

When you said you had positive on both sides of the solenoid, I thought you were talking about the small posts.

What is the serial number of the cart to make sure we are talking about a series drive system?
Sergio is online now   Reply With Quote
Unread 07-04-2015, 01:19 PM   #16
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: 99 club car quit running and won't charge

From what you say I think you have a bad solenoid. To check place volt meter across small terminals on solenoid. With throttle depressed you should get 48V. Next place meter across large terminals. With throttle depressed it should drop to 0V. Be careful jack up rear end, place on blocks.
jjance is offline   Reply With Quote
Unread 07-04-2015, 11:11 PM   #17
Not Yet Wild
 
Join Date: Jul 2015
Posts: 12
Default Re: 99 club car quit running and won't charge

It is a series cart, way I checked the solenoid was ground one line and checked the big post on solenoid each side was 51v I didn check with throttle pressed. I will check small post tom and do it with pettle pressed and not
Adam1greene is offline   Reply With Quote
Unread 07-05-2015, 10:07 AM   #18
Not Yet Wild
 
Join Date: Jul 2015
Posts: 12
Default Re: 99 club car quit running and won't charge

With throttle pressed I have 0 on big terminals and only 5v on small side. Throttle not pressed 57v on big and 0 on small
Adam1greene is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Club Car just quit - batteries dead & won't charge Electric Club Car
Club Bar just quit - batteries dead & won't charge Electric Club Car
03 Club Car stopped running and it will not charge please help! Electric Club Car
94 club car quit running- again Electric Club Car
2000 48V Club Car quit while running Electric Club Car


All times are GMT -5. The time now is 09:05 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.