lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-18-2015, 11:23 PM   #11
Gone Wild
 
glassk's Avatar
Club Car
 
Join Date: Dec 2011
Location: Hampton, GA
Posts: 441
Default Re: 2003 club car runs very slow

AA= DS Electric Golf Car, 48 Volt System


so I would verify cart and batteries, do the batteries have three or four holes in them,...
glassk is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-19-2015, 09:58 AM   #12
Gone Wild
Club Car
 
Join Date: Sep 2012
Location: Alberta - Canada
Posts: 998
Default Re: 2003 club car runs very slow

So to be specific, if you put 6v batteries in a cart designed for 8v batteries, it would behave EXACTLY like you described in your first post.
joesam is offline   Reply With Quote
Unread 07-19-2015, 10:30 AM   #13
Gone Wild
 
teecro's Avatar
Club Car
 
Join Date: Jun 2014
Location: Sunset Bay, TN
Posts: 2,214
Default Re: 2003 club car runs very slow

Looks like these guys nailed it... If you have an AA which has the electronic controller it has a 48 volt system, only the V-Guide was in 36 volts...
teecro is offline   Reply With Quote
Unread 07-19-2015, 11:04 AM   #14
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 4,583
Default Re: 2003 club car runs very slow

Never mind....

Last edited by Sergio; 07-19-2015 at 11:05 AM.. Reason: misread info
Sergio is online now   Reply With Quote
Unread 07-19-2015, 06:05 PM   #15
Gone Wild
 
kdeerman's Avatar
E-Z-GO
 
Join Date: Feb 2010
Location: Alabama
Posts: 450
Default Re: 2003 club car runs very slow

Quote:
Originally Posted by ccfanatic View Post
unplug the two wire connector and jump the harness with a paper clip

something else to try, with the key in the off position, press and release the go pedal 50 times. It cleans the track inside the mcor

if either test solves your problem, you need a new mcor
i have a 2002 or 2003 ds iq that is surging and moving a foot or so then nothing. I pumped the pedal 50 times, then jumped the two pin harness connector with a large paper clip, still the same. Is there another test for the mcor?
kdeerman is offline   Reply With Quote
Unread 07-19-2015, 06:15 PM   #16
Gone Wild
 
teecro's Avatar
Club Car
 
Join Date: Jun 2014
Location: Sunset Bay, TN
Posts: 2,214
Default Re: 2003 club car runs very slow

Quote:
Originally Posted by teecro View Post
Looks like these guys nailed it... If you have an AA which has the electronic controller it has a 48 volt system, only the V-Guide was in 36 volts...
Also to keep in mind that there are 2 different versions running 48 volts; one is the Power Drive with a F/R LEVER and the other is the IQ which has a small F/R Switch and a Tow/Run Switch too. The 36 volt with V-Glide has resisters coils and no electronic controller. Double check your pack voltage to confirm which batteries you installed and go from there...
teecro is offline   Reply With Quote
Unread 07-19-2015, 08:07 PM   #17
Gone Wild
 
kdeerman's Avatar
E-Z-GO
 
Join Date: Feb 2010
Location: Alabama
Posts: 450
Default Re: 2003 club car runs very slow

My serial begins with AQ0235, Is this an IQ model, year 2002? Thanks
kdeerman is offline   Reply With Quote
Unread 07-19-2015, 08:25 PM   #18
Gone Wild
Club Car
 
Join Date: Apr 2014
Location: Oregon City, Or
Posts: 1,939
Default Re: 2003 club car runs very slow

kdeerman- teecro answered in your other thread. Hijacking this thread doesn't help and yes it's an IQ.


.
tag50 is offline   Reply With Quote
Unread 07-19-2015, 08:36 PM   #19
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,978
Default Re: 2003 club car runs very slow

Ncseadad,
At this point it would help if you post a photo of your battery compartment, and the serial number of your cart.
mrgolf is offline   Reply With Quote
Unread 07-20-2015, 09:03 AM   #20
Gone Wild
Mixed Breed
 
Join Date: Jan 2009
Location: North Topsail Beach, NC
Posts: 221
Default Re: 2003 club car runs very slow

OK Guys...My Mistake..The first two post I posted are correct..This is a 2003 Club Car IR, AA0333-311230, 48 volt..Yes, Im getting old and have too many carts in the yard at one time....
My original post I stated that the test to test the mcor wires were different from this cart...My three wires at the three pin connector are black, purple and yellow...the two at the two pin connector are blue and green...so I didn't know according to the manual which wires was suppose to have what on it...

I will try all the suggestions that have been posted above today...however if any one has instructions with the correct color wires please let me know...

I will get back to to all soon....Thanks and again. sorry for the confusion.

Bill

Last edited by ncseadad; 07-20-2015 at 09:12 AM.. Reason: In addition....F/R switch below knee and NO tow/run switch
ncseadad is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2003 V Glide runs slow Electric Club Car
93 club car runs slow at first Electric Club Car
2003 Club car DS Runs then slows to a crawl Electric Club Car
2003 Club Car Ds Slow Go Electric Club Car
1985 club car runs slow Electric Club Car


All times are GMT -5. The time now is 11:14 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.