lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-20-2015, 10:48 AM   #21
Gone Wild
 
kdeerman's Avatar
E-Z-GO
 
Join Date: Feb 2010
Location: Alabama
Posts: 450
Default Re: 2003 club car runs very slow

Quote:
Originally Posted by tag50 View Post
kdeerman- teecro answered in your other thread. Hijacking this thread doesn't help and yes it's an IQ.


.
OK, Thanks
kdeerman is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-20-2015, 11:16 AM   #22
Gone Wild
Mixed Breed
 
Join Date: Jan 2009
Location: North Topsail Beach, NC
Posts: 221
Default Re: 2003 club car runs very slow

Hey..CCFantic...or anyone else that might know...I did the test you suggested, turn the key off and pressed the gas pedal about 50 to 75 times and it works right for the time being....before I couldn't go but about 50 yards before it would shut off...wait a few hours then it would go again...after your test I have driven several miles and it is working right...

Now, my question, is that a FIX because it was dirty inside or do I need to go ahead and get a MCOR...

Thanks
ncseadad is offline   Reply With Quote
Unread 07-20-2015, 12:11 PM   #23
DS Drivers Club Founder
 
CCFanatic's Avatar
Club Car
 
Join Date: Jul 2013
Location: Upstate NY
Posts: 3,409
Default Re: 2003 club car runs very slow

You will need an MCOR as it is only a matter of time until the symptoms return
CCFanatic is offline   Reply With Quote
Unread 08-07-2015, 07:11 PM   #24
Gone Wild
Mixed Breed
 
Join Date: Jan 2009
Location: North Topsail Beach, NC
Posts: 221
Default Re: 2003 club car runs very slow

hum my message didn't go through....trying again...OK Guys, New MCOR and cart still doing the same thing...I did the test of turning off key and pumping peddle 50 times and it seemed to work correct for a day or so, then back to the same thing...It would go about 50 feet then loose power as if the batteries were bad...It would try to move, but no go..this is in forward and reverse..I ordered and installed a new MCOR and it does the exact same thing...It will go F/R for a short distance 50 feet then to a sudden halt. You can mash the peddle and it will try to move but goes nowhere...Batteries/cables are good with 50 plus volts...

Any help would be appreciated...
Thanks Bill
ncseadad is offline   Reply With Quote
Unread 08-07-2015, 07:35 PM   #25
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,081
Default Re: 2003 club car runs very slow

weird - what control is in the cart?
scottyb is offline   Reply With Quote
Unread 08-08-2015, 10:17 AM   #26
Gone Wild
Mixed Breed
 
Join Date: Jan 2009
Location: North Topsail Beach, NC
Posts: 221
Default Re: 2003 club car runs very slow

Scottyb....Im tying to send you a picture of the controller....Until I can get it to go through..

Its a plain silver box, no stickers or plates anywhere that I can see with kind/model/numbers...Left side has the 3 larger wires and I think 3 smaller wires...No plug in plugs...

Still trying to get you a picture..

Thanks
ncseadad is offline   Reply With Quote
Unread 08-08-2015, 10:47 AM   #27
Gone Wild
Mixed Breed
 
Join Date: Jan 2009
Location: North Topsail Beach, NC
Posts: 221
Default Re: 2003 club car runs very slow

OK...having trouble getting a picture on here..

It is a Curtis and I think a PMC...it has the ribs running parallel with controller...I got this info from looking on ebay...

Hope this helps..
Thanks
Bill
ncseadad is offline   Reply With Quote
Unread 08-09-2015, 01:53 PM   #28
Gone Wild
Mixed Breed
 
Join Date: Jan 2009
Location: North Topsail Beach, NC
Posts: 221
Default Re: 2003 club car runs very slow

Hummm...No one seems to know....Let me add this and maybe it will hit a spark in some ones mind...

Keep in mind ..Cart after sitting for a day, will move 25 feet and stop...after that the solenoid clicks when you first push peddle but cart don't try to move until peddle is pushed almost to the floor, then just rocks...want go anywhere.


On the red cable going to the motor there is 50plus volts when the solenoid clicks...also noticed there is voltage on all the motor post....If I remember one is 50 and two of the studs are about 17 volts..

Any suggestions or anyone want to know voltage somewhere let me know...

BTW..new MCOR
ncseadad is offline   Reply With Quote
Unread 10-12-2015, 04:29 PM   #29
Gone Wild
Mixed Breed
 
Join Date: Jan 2009
Location: North Topsail Beach, NC
Posts: 221
Default Re: 2003 club car runs very slow

OK my golf cart buds...This post seems to got lost along the way a couple times mainly because I post the wrong information on the cart.and some how ended up on two different post....In the end, I put on a new MCOR that did no good, while retesting the controller, I pretty much blew up sending out a lot of grey smoke..Replaced the controller and everything works great...Thanks for all the help...
ncseadad is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2003 V Glide runs slow Electric Club Car
93 club car runs slow at first Electric Club Car
2003 Club car DS Runs then slows to a crawl Electric Club Car
2003 Club Car Ds Slow Go Electric Club Car
1985 club car runs slow Electric Club Car


All times are GMT -5. The time now is 11:08 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.