lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-18-2015, 01:28 PM   #1
Not Yet Wild
 
Join Date: Jul 2015
Posts: 2
Default Precedent Lightning Zap Issues

Full disclosure, house was hit by lightning with the 2008 Precedent plugged into the charger. Charger seems to work fine.

Car now starts out smartly and then quickly dumbs down to half speed as described in the speed sensor sticky. It failed the speed sensor test so I installed a new speed sensor and magnet, still moves out smartly and then dumbs down to half speed.

The local cart shop says "it could be anything." I was hoping this forum could help me get a little closer to the source of the problem than "anything" after having changed the speed sensor. Anyone know what I should try next?

Thanks
Tom
R7000 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-18-2015, 02:01 PM   #2
Not Yet Wild
 
Krazy-K's Avatar
Club Car
 
Join Date: May 2015
Location: Chesterfield MI
Posts: 29
Default Re: Precedent Lightning Zap Issues

Did it fail roll away test again? What speed sensor did you get. I read aftermarket ones are no good. Oh ya what's the vin. Is it excel cart or not?
Krazy-K is offline   Reply With Quote
Unread 07-18-2015, 03:04 PM   #3
Not Yet Wild
 
Join Date: Jul 2015
Posts: 2
Default Re: Precedent Lightning Zap Issues

The speed sensor I got was item number 181582551660 on ebay. I'll have to do the test again to answer the test question.
R7000 is offline   Reply With Quote
Unread 07-18-2015, 05:05 PM   #4
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,030
Default Re: Precedent Lightning Zap Issues

Do the speed sensor test again. The sensor you bought is definitely an aftermarket Chinese sensor. You can tell by the wire coloring. A factory sensor has Green, Red, and Black wires, where the Chinese ones have Blue, Red, and Black. I don't even attempt to use the aftermarket ones anymore. I've had terrible luck with them as have lots of other people on this forum. We sell the OEM sensors on our web store if you're interested.
TahoeDawgZ71 is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
07 ds lightning strike Electric Club Car
08 precedent issues Electric Club Car
Possible lightning Electric Club Car
Still having issues with precedent Electric Club Car


All times are GMT -5. The time now is 05:59 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.