lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-22-2015, 12:06 PM   #1
Not Yet Wild
 
Join Date: Jul 2009
Posts: 9
Default Is this signs of a bad speed sensor?

2002 Club Car IQ, we had problems with the cart running slow, but the batteries were charging properly. MY father in law took the cart to a place and they replaced the speed sensor. Since we got it back with the new sensor, when you are riding at full speed and go down an incline you can feel the cart pulsing. And when I had the cart loaded with a few adults over the weekend, if I was going at full speed and took my foot off the pedal, it would brake real hard, beep and flash the battery light. It does not brake hard or beep when it's just me and my daughter. From what I've read, this behavior could also be related to the speed sensor, correct??
polishdon is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-27-2015, 03:10 PM   #2
Not Yet Wild
 
Join Date: Jul 2009
Posts: 9
Default Re: Is this signs of a bad speed sensor?

Bueller, Bueller??
polishdon is offline   Reply With Quote
Unread 07-27-2015, 03:43 PM   #3
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 4,561
Default Re: Is this signs of a bad speed sensor?

The symptom of having the buzzer beep, flash, etc during a Regen condition (pedal up), on a 2002 IQ is most likely a "main dropout" problem.

Club car has a part for around $20 to fix that issue:
102355201 - HARNESS- MAIN DROPOUT -IQ
It is a short harness with a diode that goes in line with the Tow/Run switch.
Sergio is offline   Reply With Quote
Unread 07-28-2015, 12:24 PM   #4
Not Yet Wild
 
Join Date: Jul 2009
Posts: 9
Default Re: Is this signs of a bad speed sensor?

Thanks Sergio!!
polishdon is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
MCOR? Speed Sensor? Controller? Cart Runs at half speed. Advice, please. Electric Club Car
08 precedent electric speed sensor problem. Cart starts at proper speed then slows . Electric Club Car
Bad speed sensor or something else? Electric Club Car
Does the speed sensor affect reverse speed? Electric Club Car
Half speed, speed sensor problem?. Electric Club Car


All times are GMT -5. The time now is 12:59 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.