lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-08-2015, 09:59 PM   #11
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,052
Default Re: New XCT400 IQ installed now battery probs?

Post a pic of the whole area under the seat.
scottyb is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-09-2015, 12:16 AM   #12
Not Yet Wild
 
AWandKW's Avatar
Club Car
 
Join Date: Apr 2014
Location: Midwest
Posts: 47
Default Re: New XCT400 IQ installed now battery probs?

Left the campground tonight before I saw this post. :(

Doing some interwebbings I am pretty sure the 2009 is able to mount 4 -12s or 6 - 8 volts without any modifications! (Not including cables )

I am picking up batteries from SAMs tomorrow morning and if rain holds off - I'll try and mount em.

I also will snap a couple of pics of my XCT400IQ mount as well.

AWandKW is offline   Reply With Quote
Unread 08-09-2015, 05:25 PM   #13
Not Yet Wild
 
AWandKW's Avatar
Club Car
 
Join Date: Apr 2014
Location: Midwest
Posts: 47
Default Re: New XCT400 IQ installed now battery probs?

6 - 8volt batteries fit perfectly!

I couldn't be happier. She's charging up now. Thanks to everyone for their help.
Attached Images
File Type: jpg image.jpg (171.7 KB, 0 views)
AWandKW is offline   Reply With Quote
Unread 08-09-2015, 06:08 PM   #14
Not Yet Wild
 
Twincam47's Avatar
Club Car
 
Join Date: Jul 2015
Location: Lake Conroe, Texas
Posts: 31
Default Re: New XCT400 IQ installed now battery probs?

I also have an 09 Precedent with 4-12V batts. Let us know what speeds you are achieving and other mods done to your cart.

Thanks
Twincam47 is offline   Reply With Quote
Unread 08-09-2015, 10:14 PM   #15
Not Yet Wild
 
AWandKW's Avatar
Club Car
 
Join Date: Apr 2014
Location: Midwest
Posts: 47
Default Re: New XCT400 IQ installed now battery probs?

I would love to!
Just with stock controller setting 3 (?) and the larger tires i had it to 23mph.

The 6 batteries were an easy fit! I removed a plastic piece that was made to be removed on the tub floor. It held the 2 inner batteries of the original 4. With that removed the 6 batteries seemed easier than lifting those huge 12v ones in place.
I also had to modify hold down plastic, took 2 seconds with pliers. I had to remove the top so it would fit over the carrying lugs on top of two middle batteries. I can get a better pic if you need it.

Now with new batteries, 4 ga cables, heave duty solenoid and the XCT400IQ controller I'm really excited to see what it'll do after the battery break in period.
AWandKW is offline   Reply With Quote
Unread 08-09-2015, 11:57 PM   #16
Not Yet Wild
 
Twincam47's Avatar
Club Car
 
Join Date: Jul 2015
Location: Lake Conroe, Texas
Posts: 31
Default Re: New XCT400 IQ installed now battery probs?

Guess I will be contacting ScottyB>
A couple of pic of how you mounted the controller would be nice also.
Twincam47 is offline   Reply With Quote
Unread 08-10-2015, 09:38 PM   #17
Gone Wild
 
buckmanmike's Avatar
 
Join Date: Oct 2007
Location: Snellville, Ga.
Posts: 1,062
Default Re: New XCT400 IQ installed now battery probs?

I have energizer 8v batteries from Sams. Dated 08/08. I've had good service out of them, but they are tired now. Will be replacing next week with Trojan 875s. Found Trojans for only $15 more each, so decided to go that route.
buckmanmike is offline   Reply With Quote
Unread 08-11-2015, 11:16 PM   #18
Not Yet Wild
 
AWandKW's Avatar
Club Car
 
Join Date: Apr 2014
Location: Midwest
Posts: 47
Default Re: New XCT400 IQ installed now battery probs?

I was able to take a couple pictures of the XCT400IQ install I purchased from scottyb.
Attached Images
File Type: jpg image.jpg (167.8 KB, 0 views)
AWandKW is offline   Reply With Quote
Unread 08-11-2015, 11:18 PM   #19
Not Yet Wild
 
AWandKW's Avatar
Club Car
 
Join Date: Apr 2014
Location: Midwest
Posts: 47
Default Re: New XCT400 IQ installed now battery probs?

I had to trim a little off the back of compartment that holds controller and solenoid.
Attached Images
File Type: jpg image.jpg (150.7 KB, 0 views)
AWandKW is offline   Reply With Quote
Unread 08-12-2015, 05:27 PM   #20
Not Yet Wild
 
Twincam47's Avatar
Club Car
 
Join Date: Jul 2015
Location: Lake Conroe, Texas
Posts: 31
Default Re: New XCT400 IQ installed now battery probs?

Thanks for the pics....you get a speed reading on her yet?
Twincam47 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Installed a battery meter below the cup holders Electric EZGO
Installed Battery Meter and now '86 Marathon won't go Electric EZGO
New to me 99 cc a few probs Electric Club Car
OBC ver. 2.05 Any probs with this version? Electric Club Car
Installed new battery and now it wonk crank! Gas EZGO


All times are GMT -5. The time now is 09:55 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.