lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-23-2015, 12:43 PM   #11
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,066
Default Re: 82 club car, runs slow if you press pedal easy, runs normal if you hit it hard?

0
Quote:
Originally Posted by Jeffreynmandy View Post
I listened for the micro switches and I did only hear 4 clicks. The first switch when you first press the pedal is the one not clicking.
that is not right .. the first two should almost be a double click as they are very close on the speed wedge.. the cart would not move if frist micro dead , but will if second is

Is there a easy way to get to them? I'll order one, or stop by and see the old man that has alot golf cart Junk.
no... you have to remove the box to get at the switches

I really appreciate the help, I like tinkering with the carts, but I'm new to it, so im starting out blind. The resistor cart does seem alot less complicated.
when you get it open and switches removed test all of them and look at your wedge

make sure it is not worn
crash test dummy is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-23-2015, 01:50 PM   #12
Gone Wild
 
Join Date: Jul 2015
Posts: 304
Default Re: 82 club car, runs slow if you press pedal easy, runs normal if you hit it hard?

I'll check it again, bUt I don't think I heard the first click until the pedal I was about half way down
Jeffreynmandy is offline   Reply With Quote
Unread 08-23-2015, 06:41 PM   #13
Gone Wild
 
Join Date: Jul 2015
Posts: 304
Default Re: 82 club car, runs slow if you press pedal easy, runs normal if you hit it hard?




The switch near the end th that's hanging lower has allot of play in it. But it will click if I press it all the way in.

That may be why if I stomp the pedal it may be making it kick in


All but one has a little play, that one has allot of play. Should I REplace them all?
Is this likely my problem?

The plastic pie piece for doesn't look worn. The switches look newer too. They have probably been replaced before.
Jeffreynmandy is offline   Reply With Quote
Unread 08-23-2015, 07:16 PM   #14
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,982
Default Re: 82 club car, runs slow if you press pedal easy, runs normal if you hit it hard?

You can check the switches with your meter. Don't know if it makes a difference but the arms can be adjusted also. On other equipment I adjusted them all the time to set up equipment to work correctly.
mrgolf is offline   Reply With Quote
Unread 08-23-2015, 07:33 PM   #15
Gone Wild
 
Join Date: Jul 2015
Posts: 304
Default Re: 82 club car, runs slow if you press pedal easy, runs normal if you hit it hard?

All the speeds are working correctly, when I hold down the first switch and then trigger another one , each speed responds with the wheels turning.


I can't figure out how to get it back together quite right, all the switches trigger at once it seems like. It's doing this while I have it back together

Edit- I think I had in backwards. I'll mess with it tomorrow. I was putting it back together and somehow touched the unhooked negative with the silver box. I think it may have fried a couple switches. :(
Jeffreynmandy is offline   Reply With Quote
Unread 08-23-2015, 08:10 PM   #16
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,066
Default Re: 82 club car, runs slow if you press pedal easy, runs normal if you hit it hard?

Quote:
Originally Posted by Jeffreynmandy View Post
All the speeds are working correctly, when I hold down the first switch and then trigger another one , each speed responds with the wheels turning.


I can't figure out how to get it back together quite right, all the switches trigger at once it seems like. It's doing this while I have it back together

Edit- I think I had in backwards. I'll mess with it tomorrow. I was putting it back together and somehow touched the unhooked negative with the silver box. I think it may have fried a couple switches. :(
backward .. yep
re check them to be sure
crash test dummy is offline   Reply With Quote
Unread 08-23-2015, 08:37 PM   #17
Gone Wild
 
Join Date: Jul 2015
Posts: 304
Default Re: 82 club car, runs slow if you press pedal easy, runs normal if you hit it hard?

Quote:
Originally Posted by crash test dummy View Post
backward .. yep
re check them to be sure

The solenoid still clicked when I pressed each switch, but each speed at the wheel didn't start. Only the last and highest speed worked.

It makes me sick. I turned it around right and retested the pedal, and yep, there was five clicks.

I just blew the switches. Either way, I'm still way ahead of where I would have been without your help.


The positive is, I mostly understand how a resistor cart works. But on the other hand, they are ancient.

Oh well, I guess I gotta start somewhere.
Jeffreynmandy is offline   Reply With Quote
Unread 08-23-2015, 08:39 PM   #18
Gone Wild
 
Join Date: Jul 2015
Posts: 304
Default Re: 82 club car, runs slow if you press pedal easy, runs normal if you hit it hard?

If I can't find some switches in town tomorrow, where would be a good place to get them online?
Jeffreynmandy is offline   Reply With Quote
Unread 08-23-2015, 09:18 PM   #19
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,066
Default Re: 82 club car, runs slow if you press pedal easy, runs normal if you hit it hard?

Quote:
Originally Posted by Jeffreynmandy View Post
The solenoid still clicked when I pressed each switch, but each speed at the wheel didn't start. Only the last and highest speed worked.
re check all wires and coils , then go to solenoids and switches
It makes me sick. I turned it around right and retested the pedal, and yep, there was five clicks.

I just blew the switches. Either way, I'm still way ahead of where I would have been without your help.

to be clear you have done the tests ?
The positive is, I mostly understand how a resistor cart works. But on the other hand, they are ancient.

Oh well, I guess I gotta start somewhere.
i started with a 93 cc
Dave he is a site sponsor and knows club cars



http://www.revolutiongolfcars.com/

tell him your a member of BGW and i told you to call him ...
crash test dummy is offline   Reply With Quote
Unread 08-23-2015, 10:24 PM   #20
Gone Wild
 
Join Date: Jul 2015
Posts: 304
Default Re: 82 club car, runs slow if you press pedal easy, runs normal if you hit it hard?

I've got my volt meter now, I'll be able to do the continuity tests to the switches and solenoids.
Jeffreynmandy is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2003 club car runs very slow Electric Club Car
93 club car runs slow at first Electric Club Car
Motor runs when pedal is pushed but slow to move. Gas EZGO
1985 club car runs slow Electric Club Car
Club Car runs slow in reverse Electric Club Car


All times are GMT -5. The time now is 04:08 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.