lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-02-2015, 11:28 AM   #1
Not Yet Wild
 
Join Date: Apr 2014
Posts: 5
Default Whats the problem?

I have a 93 club car and I've replaced the motor controller, Solenoid and two of the batteries. All six show at least 6 volts. Found the limit switch in the gas pedal thingy bad and replaced it but soon as I hit the gas pedal it fried again, its not reverse or middle limit switch, its the third one. Any ideas?
1scooper is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-02-2015, 12:00 PM   #2
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,042
Default Re: Whats the problem?

The third switch being the most forward of the 3 switches? I believe you have reversed the position of the small solenoid wires. Post up a pic showing the + sign on the solenoid and small wires attached..... please don't zoom in too tight. we need to see what wire goes where.
scottyb is offline   Reply With Quote
Unread 09-02-2015, 12:53 PM   #3
Not Yet Wild
 
Join Date: Apr 2014
Posts: 5
Default Re: Whats the problem?

20150902_124004.jpg
1scooper is offline   Reply With Quote
Unread 09-02-2015, 02:33 PM   #4
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,042
Default Re: Whats the problem?

Or in this case simply installed the diode backwards which creates a direct short when the solenoid is activated and usually (not always) burns up a micro switch like a fuse link.
scottyb is offline   Reply With Quote
Unread 09-02-2015, 03:00 PM   #5
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,960
Default Re: Whats the problem?

Scottyb is absolutely correct and by the photograph it appears that you have the diode on backwards. However I'd like to add something else to the mix. That solenoid looks very short compared to the one it's supposed to have. What solenoid is that?
TahoeDawgZ71 is offline   Reply With Quote
Unread 09-02-2015, 04:30 PM   #6
Not Yet Wild
 
Join Date: Apr 2014
Posts: 5
Default Re: Whats the problem?

I was told it is the one for that cart and it is the same size I took off.
1scooper is offline   Reply With Quote
Unread 09-02-2015, 09:33 PM   #7
Not Yet Wild
 
Join Date: Apr 2014
Posts: 5
Default Re: Whats the problem?

Well I've got the solenoid to click but motor still not doing anything. What do I try next, Is there a way to check motor? The controller is new. Could it be the wiper thing that hooks to the gas pedal?
1scooper is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
So, whats next? Electric EZGO


All times are GMT -5. The time now is 06:36 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.