lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-05-2015, 02:58 PM   #1
HCC
Not Yet Wild
 
Join Date: Sep 2015
Posts: 1
Default 48v club car charged won't run

I have a 48v club car yesterday I was using it and it suddenly stopped working I could here solenoid clicking but wouldn't go forward or reverse. After about 5 minutes it started to work again for about an hour then quit for good. The batteries are fully charged and full of water. The only way I can get it to somewhat run is with it plugged in, it puts the batteries at about 56v and it try to run the solenoid just clicks on and off really fast but it moves. As soon as I unplug it solenoid will click on but no movement. I have reset the controller multiple times and still no luck. Any thoughts would be very helpful I am stuck.
HCC is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-05-2015, 03:13 PM   #2
Gone Wild
Club Car
 
Join Date: Oct 2008
Location: East Texas
Posts: 318
Default Re: 48v club car charged won't run

What is the battery voltage? How did you reset the controller? It might help to know which 48V club you have as well, DS or Precedent and Regen or Series? I would put a meter on the pack, then if you have 50.8V or greater, what does the meter show when you hit the gas pedal?
basshawk84 is offline   Reply With Quote
Unread 09-05-2015, 03:14 PM   #3
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,081
Default Re: 48v club car charged won't run

The solenoid does the chatter when voltage is too low. So bad battery (batteries) or loose high amperage power connection
scottyb is online now   Reply With Quote
Unread 09-05-2015, 04:30 PM   #4
Gone Wild
 
Join Date: Aug 2011
Posts: 384
Default Re: 48v club car charged won't run

Sounds like the OBC it runs with the charger plugged in
greg-g is offline   Reply With Quote
Unread 09-05-2015, 06:26 PM   #5
Gone Wild
 
glassk's Avatar
Club Car
 
Join Date: Dec 2011
Location: Hampton, GA
Posts: 441
Default Re: 48v club car charged won't run

Quote:
Originally Posted by HCC View Post
I have a 48v club car yesterday I was using it and it suddenly stopped working I could here solenoid clicking but wouldn't go forward or reverse. After about 5 minutes it started to work again for about an hour then quit for good. The batteries are fully charged and full of water. The only way I can get it to somewhat run is with it plugged in, it puts the batteries at about 56v and it try to run the solenoid just clicks on and off really fast but it moves. As soon as I unplug it solenoid will click on but no movement. I have reset the controller multiple times and still no luck. Any thoughts would be very helpful I am stuck.
Plugged in locks out movement,
glassk is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Club Car won't run with fully charged batteries Electric Club Car
1990 club car - charged but won't move Electric Club Car
Club Car fully charged, hear relay click, still won't drive Electric Club Car
not charged Electric Club Car
92 Club car was charged with key left on and in forward now wont move! Electric Club Car


All times are GMT -5. The time now is 08:58 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.