lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-18-2015, 10:19 AM   #21
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: Club car Precedent sat in the rain now won't run

Any more input for me to check the issue. I am confused why the solenoid has full voltage on both the small terminals on it. But I don't know the shunt system very well either.
grandpa1 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-18-2015, 07:15 PM   #22
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,975
Default Re: Club car Precedent sat in the rain now won't run

Is that full voltage without pedal pressed or what.
mrgolf is online now   Reply With Quote
Unread 10-18-2015, 07:52 PM   #23
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: Club car Precedent sat in the rain now won't run

I will have to double check it again but I believe it was with pedal up
grandpa1 is offline   Reply With Quote
Unread 10-19-2015, 09:26 AM   #24
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: Club car Precedent sat in the rain now won't run

Full voltage on both small terminals of solenoid key on in run position no pedal depressed.
grandpa1 is offline   Reply With Quote
Unread 10-19-2015, 11:21 AM   #25
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,975
Default Re: Club car Precedent sat in the rain now won't run

If I understand correctly the solenoid is engaged as soon as the key is turned on.
I may be wrong but I think it should only engage when you press the pedal. The way it is now makes the controller think you have the pedal pressed when you turn the key on. I don't think the cart will work if you hold the pedal down before you turn the key on. So unhook the two pin connector on the mcor and see if you still have voltage on the solenoid small wires.

Disclaimer: I am just guessing here but I might be on the right track.
mrgolf is online now   Reply With Quote
Unread 10-19-2015, 11:52 AM   #26
Gone Wild
 
glassk's Avatar
Club Car
 
Join Date: Dec 2011
Location: Hampton, GA
Posts: 441
Default Re: Club car Precedent sat in the rain now won't run

Quote:
Originally Posted by grandpa1 View Post
Full voltage on both small terminals of solenoid key on in run position no pedal depressed.
,.,

Last edited by glassk; 10-19-2015 at 11:55 AM.. Reason: forgot diode
glassk is offline   Reply With Quote
Unread 10-20-2015, 09:53 PM   #27
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: Club car Precedent sat in the rain now won't run

Ok here is where I am at. Found some cut wires. I put the wire from the run/ tow switch back to the wire that goes to the 16 pin connector. Cart runs now but when I press the pedal down further it shuts down right away. I put the volt meter on the solenoid and it shows that it drops to 42 volts and shuts down. I assume it is dropping out. Also the solenoid does not make any clicking sound at all.
grandpa1 is offline   Reply With Quote
Unread 10-20-2015, 10:42 PM   #28
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,975
Default Re: Club car Precedent sat in the rain now won't run

Sound like you are getting there. Have you tried pumping the pedal with key off to see if that helps.

That also sounds like you may need the drop out harness.

These solenoid so don't make a very loud click.
mrgolf is online now   Reply With Quote
Unread 10-28-2015, 11:00 AM   #29
Not Yet Wild
 
MiamiBeacher's Avatar
Club Car
 
Join Date: Jul 2014
Location: Miami Beach
Posts: 34
Default

My cart just did the same thing. It's a DS iQ.

It was raining on the ride and when I got to my destination, a faint buzz from the reverse buzzer is going off. I can only get it to stop by putting in Tow right now. Looking further into it now. But I'm not sure. It's not a full volume buzz, it's very faint. And the cart is in like super limp mode.


Sent from my iPhone using Tapatalk
MiamiBeacher is offline   Reply With Quote
Unread 10-28-2015, 11:25 AM   #30
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 4,564
Default Re: Club car Precedent sat in the rain now won't run

Put the cart on Tow, disconnect the 16-pin connector from the controller and make sure it is dry (use a hair drier).

It sounds like you may have water in the speed sensor pins at that connector.
Sergio is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Club Car DS rain enclosure w/doors Golf Carts and Parts
rain cover, club,ez go cars Golf Carts and Parts


All times are GMT -5. The time now is 11:12 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.