lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-21-2015, 10:24 AM   #1
Not Yet Wild
 
Join Date: Jul 2011
Posts: 4
Default Precedent has lost speed

Bought a 2013 Precedent last year. Has now lost speed but still has power to go up hills. When I press accelerator to floor, it starts to speed up but then slows to about half speed, as if it has a governor.
bcarr is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-21-2015, 10:28 AM   #2
Not Yet Wild
Club Car
 
Join Date: Jul 2015
Location: Maiden NC
Posts: 49
Default Re: Precedent has lost speed

Sounds like an MCOR problem.
bakerm07 is offline   Reply With Quote
Unread 10-21-2015, 10:46 AM   #3
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,978
Default Re: Precedent has lost speed

Put cart in Tow wait a few minutes then back to Run, if that don't fix it you may have a bad speed sensor. release brake and try pushing cart, it should try to stop and beep, if not the speed sensor is bad.
mrgolf is offline   Reply With Quote
Unread 10-21-2015, 01:36 PM   #4
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,985
Default Re: Precedent has lost speed

Bad speed sensor. You need to order a speed sensor for the ADC motor. Don't get the cheap ones from eBay. Get a good quality American Made sensor and it'll last.
TahoeDawgZ71 is online now   Reply With Quote
Unread 10-23-2015, 03:50 AM   #5
Getting Wild
 
Join Date: Oct 2012
Posts: 90
Default Re: Precedent has lost speed

If a high speed magnet is installed currently, will the speed sensor test still work?
dc_customdesign is offline   Reply With Quote
Unread 10-23-2015, 08:12 AM   #6
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,978
Default Re: Precedent has lost speed

Yes, The speed sensor still works, should beep because of roll away braking and try so stop.
mrgolf is offline   Reply With Quote
Unread 10-23-2015, 09:15 AM   #7
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,985
Default Re: Precedent has lost speed

Mrgolf is correct. You may just have to push it a little bit faster to make it engage.
TahoeDawgZ71 is online now   Reply With Quote
Unread 10-23-2015, 10:20 PM   #8
Getting Wild
 
Join Date: Oct 2012
Posts: 90
Default Re: Precedent has lost speed

What should the "normal speed" be for a 06 Precedend with a high speed magnet? I'm sure the battery's aren't good, the other day, my brother and I got a top speed of 10mph on flat. A couple weeks before that I got 16 on flat land and 18 down hill.
dc_customdesign is offline   Reply With Quote
Unread 10-23-2015, 10:24 PM   #9
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,985
Default Re: Precedent has lost speed

Quote:
Originally Posted by dc_customdesign View Post
What should the "normal speed" be for a 06 Precedend with a high speed magnet? I'm sure the battery's aren't good, the other day, my brother and I got a top speed of 10mph on flat. A couple weeks before that I got 16 on flat land and 18 down hill.
19-22 mph with perfect front end alignment, properly inflated tires, no brake drag, no hub drag, and one person riding it.
TahoeDawgZ71 is online now   Reply With Quote
Unread 10-23-2015, 10:30 PM   #10
Getting Wild
 
Join Date: Oct 2012
Posts: 90
Default Re: Precedent has lost speed

Ok. Thanks!
dc_customdesign is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Lost my speed... Electric Club Car
lost on speed controlles Electric Club Car
08 Precedent lost speed Electric Club Car
ezgo speed lost Electric EZGO


All times are GMT -5. The time now is 09:44 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.