lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-28-2015, 09:01 PM   #1
Not Yet Wild
Club Car
 
Join Date: Oct 2015
Location: Mobile, AL
Posts: 9
Default Just stopped...need advice...

Here is intro & cart detail...http://www.buggiesgonewild.com/intro...bie-going.html

Budget is tight, so yesterday I replaced the 3 weakest batteries. The cart was still extremely slow. Then this evening after a couple slow short rides it wouldn't do anything; I slammed on gas and WOW, we took off. Rode for awhile, starting and stopping a few times, all at new expected speed. I knew cart had sat outside for years and assumed my contacts were dirty and causing issue. Well at the end of the evening I went to end of the road, turned around, slammed peddle & nothing; I never could get going again. As stated in intro I'm not sure this year has the MCOR, so where do I start? I plan to jack up, disassemble, and clean all contacts, but is there something specific to look for? Possible I broke something slamming? Thanks in advance.

Accountability is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-28-2015, 09:44 PM   #2
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,051
Default Re: Just stopped...need advice...

mocr is under cart on frame rail



if you have it then jump the plug to see if MOCR is bad

unplug the 2 prong plug (#4)
squeeze the tabs , pull hard
put a paper clip or a wire in the plug and test cart
crash test dummy is offline   Reply With Quote
Unread 10-28-2015, 10:06 PM   #3
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,889
Default Re: Just stopped...need advice...

MCORs weren't introduced until 2001, you probably have a V-glide unless the cart has been upgraded to an MCOR. A v-glide is a black pie shaped box placed between the batteries on the driver's side.
jakesnake27 is offline   Reply With Quote
Unread 10-28-2015, 10:14 PM   #4
Not Yet Wild
Club Car
 
Join Date: Oct 2015
Location: Mobile, AL
Posts: 9
Default Re: Just stopped...need advice...

^^ V-glide is what I have. Can I test, disassemble & clean, etc...?
Accountability is offline   Reply With Quote
Unread 10-28-2015, 10:22 PM   #5
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,051
Default Re: Just stopped...need advice...

yep
check wiper switch for ware

crash test dummy is offline   Reply With Quote
Unread 10-29-2015, 07:44 AM   #6
Not Yet Wild
Club Car
 
Join Date: Oct 2015
Location: Mobile, AL
Posts: 9
Default Re: Just stopped...need advice...

Thanks! It will be Saturday morning before I get a chance to get into. If I have significant ware can I easily find replacement?
Any chance you have figure 17-17 you could share?
Accountability is offline   Reply With Quote
Unread 10-29-2015, 12:37 PM   #7
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,051
Thumbs up Re: Just stopped...need advice...






contact Dave (TahoeDawgZ71) at revolution golf cars he is the guy for Club Car parts
tell him about this post
Email: info@revolutiongolfcars.com
make sure you tell him your carts volts
crash test dummy is offline   Reply With Quote
Unread 10-29-2015, 02:55 PM   #8
Not Yet Wild
Club Car
 
Join Date: Oct 2015
Location: Mobile, AL
Posts: 9
Default Re: Just stopped...need advice...

Thanks! I have already reached out to Dave. I'm in a rush to hopefully have going for kids/Halloween, so I am going to attempt breakdown and cleaning of V-Glide. After research and exchange with Dave I'm sure, regardless of results, I'll get the MCOR conversion kit from Revolution soon.
Accountability is offline   Reply With Quote
Unread 11-01-2015, 12:07 PM   #9
Not Yet Wild
Club Car
 
Join Date: Oct 2015
Location: Mobile, AL
Posts: 9
Default Re: Just stopped...need advice...

I discovered slamming petal I did indeed break something; V- glide housing. As mentioned just wanted to get running and do MCOR upgrade; I rigged/band-aided housing to keep in place and now I am same place as this member...
1995 Club Car won't move

I had on jack stands yesterday and in either forward or reverse wheels would start to roll and just stop. One difference I have from thread above is occasionally as I play with trying to get going my battery light on dash comes on. I have over 50v across the pack.

BTW - there was a lot of pad left before wear indicator on v-glide arm.
Accountability is offline   Reply With Quote
Unread 11-02-2015, 10:03 AM   #10
Not Yet Wild
Club Car
 
Join Date: Oct 2015
Location: Mobile, AL
Posts: 9
Default Re: Just stopped...need advice...

I thought I had done all the available tests I had read with volt meter, but apparently did not do each correctly. I feared my issue might be my motor and after searching through years of old threads I saw way to bypass solenoid to test it that would test motor too; jack up rear end, remove wires from 1 large terminal, and put all on other terminal. Worked like a champ, forward and reverse. Luckily I had another solenoid I pulled off scrap/parts cart me and another neighbor were using, and for now I am working like a champ; v-glide band-aide and all. After mid-November trip I will upgrade to MCOR, and then start the add-on/upgrades; lights, mirrors, blue-tooth bar, etc...

Thanks BGW! I have spent countless hrs searching and reading. I feel like a might have a good one, since most of the threads I find with same year 48v cars with issues are Regen systems.

I do have a question for the experts...Is there any differences between these two solenoids...

http://www.buggiesunlimited.com/product.asp?sku=1118

http://www.buggiesunlimited.com/product.asp?sku=5722

The 1st is like what I pulled off for 95-97, but the spare cart is a 2001 model and the one I put on is like the second. It appears to just be in layout and cart is working fine, but I want to make sure I not opening up possibility for more issues.

Last edited by Accountability; 11-02-2015 at 10:23 AM.. Reason: adding content
Accountability is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
G1 just stopped...what now Gas Yamaha
98 EZ Go stopped Electric EZGO
G19 just stopped! Electric Yamaha
Ez go just stopped Electric EZGO


All times are GMT -5. The time now is 02:20 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.