lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-05-2015, 07:18 PM   #1
Not Yet Wild
 
Join Date: Nov 2015
Posts: 3
Angry 2013 Precedent charging problem...

New to this forum and appreciate the information that I've already received. I have a 2013 Club Car Precedent with a Club Car Power Drive 3 charger. My problem is that the charger will click on when it's plugged into the cart but does not charge. My batteries currently show 49.2 across the pack and I leave the charger plugged in when the cart isn't in use. I plugged another charger into my cart with the same results, no charge. I've attempted reset on the obc with negative results so I'm thinking it's the obc. I have to add that I've always had EZ-GO carts and was pretty good at fixing problems with them but I was talked into this Precedent by a brother and I have no clue what the heck I'm doing with it. I'm not really even sure where the obc is located. Any help would be appreciated. Otherwise I may be in search of an ezgo...
sarge160 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-05-2015, 07:53 PM   #2
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,978
Default Re: 2013 Precedent charging problem...

One of the first things I would check is see if the wires from charge plug are connected. Red to pack pos. Black to obc. The 10 gauge red wire to pos. Seems to be bad for corrosion it can loose connection even though it is hooked up.
mrgolf is offline   Reply With Quote
Unread 11-05-2015, 08:59 PM   #3
Not Yet Wild
 
Join Date: Nov 2015
Posts: 3
Default Re: 2013 Precedent charging problem...

Thanks Mr Golf, I already pulled on the wires in the back of the charging port and they appear to be tight but I'll take a closer look at them tomorrow. Hopefully this isn't a major problem...
sarge160 is offline   Reply With Quote
Unread 11-05-2015, 09:03 PM   #4
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,002
Default Re: 2013 Precedent charging problem...

The on-board computer can be easily deleted from the system. There are several different aftermarket chargers that you can purchase for slightly more than a new OBC. These chargers are considered smart chargers and will work on their own without the help of the OBC to tell them what to do. The DPI accusense charger has been a popular choice for many years. I'm also a big fan of the new Lester "Summit" high frequency charger. Both are quality products.
TahoeDawgZ71 is offline   Reply With Quote
Unread 11-06-2015, 10:07 AM   #5
Not Yet Wild
 
Join Date: Nov 2015
Posts: 3
Default Re: 2013 Precedent charging problem...

Thanks for the replies. Turned out to be that the electrical receptacle that I use to plug the charger in was bad. Replaced it this morning and all is well. That never entered my mind until this morning and I feel kind of foolish for not testing it when all this started. At least it was an easy fix and and my cart is charging perfectly again. Thanks again, I'm sure I'll be a frequent visitor to this forum just to learn about Club Cars...
sarge160 is offline   Reply With Quote
Unread 11-06-2015, 10:13 AM   #6
Gone Wild
Club Car
 
Join Date: Sep 2012
Location: Alberta - Canada
Posts: 998
Default Re: 2013 Precedent charging problem...

Quote:
the charger will click on when it's plugged into the cart but does not charge
This can also occur when the breaker on your A/C outlet has tripped. Probably not (and probably too simplistic) - but plugging your charger into a different A/C outlet is worth a shot - just to eliminate the obvious.
joesam is offline   Reply With Quote
Unread 11-06-2015, 10:18 AM   #7
Gone Wild
 
teecro's Avatar
Club Car
 
Join Date: Jun 2014
Location: Sunset Bay, TN
Posts: 2,214
Default Re: 2013 Precedent charging problem...

Quote:
Originally Posted by sarge160 View Post
Thanks for the replies. Turned out to be that the electrical receptacle that I use to plug the charger in was bad. Replaced it this morning and all is well. That never entered my mind until this morning and I feel kind of foolish for not testing it when all this started. At least it was an easy fix and and my cart is charging perfectly again. Thanks again, I'm sure I'll be a frequent visitor to this forum just to learn about Club Cars...
No foolish would have been to purchase a new OBC or charger without ruling out every other option first....

BUT I will 2nd the notion of replacing the charger with a DPI and bypassing the OBC when the timing and funds allow....
teecro is offline   Reply With Quote
Reply

Tags
48v power drive, charger, club car precedent, obc
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2013 Precedent turn signal wiring problem Electric Club Car
48v precedent charging problem Electric Club Car
2012 precedent 48 volt charging problem Electric Club Car
2011 rebuilt Precedent intermittent charging problem Electric Club Car
Precedent charging problem Electric Club Car


All times are GMT -5. The time now is 04:51 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.