lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-25-2015, 09:38 AM   #1
Not Yet Wild
 
Join Date: Oct 2015
Posts: 5
Default Dead battery again!

OK, very new to the golf cart world, so bare with me. Installed (3) new batteries in the cart. 48v system. When I charged it for the first time after the battery replacement it was sluggish. So I checked the batteries and found one of the new ones was bad. Got a new one under warranty and it just did it again. When I hook up the charger it is reading 17amps. The battery is also the first one in the series. I'm not sure what yr this CC Carryall is but the serial # is FD0621-633565. Pretty sure its the charger but thought I'd get some input from you guys. Thanks
jgehle is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-25-2015, 10:23 AM   #2
Not Yet Wild
 
Join Date: Oct 2015
Posts: 5
Default Re: Dead battery again!

Just noticed the charger is hooked to the second battery in the series. Is this wrong. Thinking this is what is junking the first battery?
jgehle is offline   Reply With Quote
Unread 11-25-2015, 10:27 AM   #3
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 4,584
Default Re: Dead battery again!

It is wrong and it is definitely what is killing the first battery.

The positive from the charger receptacle needs to be connected to the pack positive battery terminal (same one as the main cable that goes to Your solenoid).
Sergio is online now   Reply With Quote
Unread 11-25-2015, 10:28 AM   #4
Gone Wild
Club Car
 
Join Date: Sep 2012
Location: Alberta - Canada
Posts: 998
Default Re: Dead battery again!

Quote:
Thinking this is what is junking the first battery
Yep! - you'd be surprised how many people change batteries, leaving the last battery "out-of-the-loop"
joesam is offline   Reply With Quote
Unread 11-25-2015, 10:52 AM   #5
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,088
Default Re: Dead battery again!

You will also be surprised by this;

Adding new batteries to an old pack will reduce the new batteries to the level and condition of the old batteries in months.

If you have bought 3 out 4/12v batteries or 3 out of 6/8v it is time to consider going for the rest of the pack.
scottyb is online now   Reply With Quote
Unread 11-25-2015, 11:01 AM   #6
Not Yet Wild
 
Join Date: Oct 2015
Posts: 5
Default Re: Dead battery again!

Soon as I seen it I knew right away. Thanks for all the advice.
jgehle is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
dead battery ??? Gas Yamaha
Battery gone dead Electric EZGO
G1 and a dead battery Gas Yamaha
dead battery Gas Club Car
battery go dead Electric EZGO


All times are GMT -5. The time now is 04:32 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.