lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-02-2015, 11:09 AM   #1
Not Yet Wild
Club Car
 
Join Date: Aug 2013
Location: Northport, Alabama
Posts: 19
Default DS 48 not going forward/reverse

Been lurking for a while.

Club Car 48 volt won't go forward or reverse. The solenoid does not click to my knowledge. Only thing I hear clicking is the MCOR when pedal is pressed.

I did notice I didn't turn key off when I charged it. Last time I used it, it seemed as if the acceleration was off per pressing the pedal.

Checking things, and both wires going to key switch are carrying 8+ volts even though disconnected from switch.

Solenoid voltage on both post was 8-10 volts with key on, pedal pressed, and in forward. I only tested with meter leads being: one on post of solenoid the another on metal, not on battery.

I thought it was supposed to be 48 volts at large post on solenoid, but maybe this is when the other lead is on the opposite charge of the battery.

Solenoid taken off, and no continuity between small post, large post or crossed.

Each battery is reading between 8.2 to 8.5 volts. All batteries together are 50.2 volts.

Fuse at charging port test fine with continuity, cables/ends are ok. two fuses off batteries are good.












Thanks for the help in advance.

God Bless,
David B.

Last edited by BOFF; 12-02-2015 at 11:29 AM.. Reason: added info
BOFF is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-02-2015, 04:25 PM   #2
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,978
Default Re: DS 48 not going forward/reverse

It don't look like the charge port wire is hooked up to main pack Pos. post
mrgolf is offline   Reply With Quote
Unread 12-02-2015, 05:49 PM   #3
Not Yet Wild
Club Car
 
Join Date: Aug 2013
Location: Northport, Alabama
Posts: 19
Default Re: DS 48 not going forward/reverse

Quote:
Originally Posted by mrgolf View Post
It don't look like the charge port wire is hooked up to main pack Pos. post
You're correct I have both sides disconnected when I was working on it. But that was done intentionally.

God Bless,
David B
BOFF is offline   Reply With Quote
Unread 12-02-2015, 06:06 PM   #4
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,978
Default Re: DS 48 not going forward/reverse

Don't use metal, or frame to check voltage. Use pack neg for correct readings.
mrgolf is offline   Reply With Quote
Unread 12-02-2015, 06:08 PM   #5
Gone Wild
Club Car
 
Join Date: Sep 2012
Location: Alberta - Canada
Posts: 998
Default Re: DS 48 not going forward/reverse

Quote:
I only tested with meter leads being: one on post of solenoid the another on metal, not on battery.
Smarter people will see this and no doubt be back to you on trouble shooting - but there is no frame ground on golf carts (you are seeing stray/ambient voltage on the frame - maybe because of grime/moisture or acid that has leaked onto the frame). To accurately troubleshoot your problem, ambient/random frame volts are just a distraction you should ignore.

Always use the main negative post for your ground / testing and reporting. You might want to re-do those tests and report the correct numbers (just to eliminate the odd numbers).

OOPS - mrgolf types faster
joesam is offline   Reply With Quote
Unread 12-02-2015, 06:27 PM   #6
Not Yet Wild
Club Car
 
Join Date: Aug 2013
Location: Northport, Alabama
Posts: 19
Default Re: DS 48 not going forward/reverse

Quote:
Originally Posted by joesam View Post
Smarter people will see this and no doubt be back to you on trouble shooting - but there is no frame ground on golf carts (you are seeing stray/ambient voltage on the frame - maybe because of grime/moisture or acid that has leaked onto the frame). To accurately troubleshoot your problem, ambient/random frame volts are just a distraction you should ignore.

Always use the main negative post for your ground / testing and reporting. You might want to re-do those tests and report the correct numbers (just to eliminate the odd numbers).

OOPS - mrgolf types faster
I will. That is one reason I posted how I tested it, as I suspected it was done wrong after further research.

Will be tomorrow before I have results.

God Bless,
David B.
BOFF is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Forward/Reverse, drives forward then jumps in reverse Electric EZGO
2006 ezgo forward is reverse and reverse is forward please help Electric EZGO
Reverse alarm sounds in Forward, wont go forward or reverse Electric Club Car
Alarm sounding in forward. No movement in forward or reverse Electric Club Car
Forward Reverse switch melted on forward...have question about replacement part Electric Club Car


All times are GMT -5. The time now is 09:06 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.