lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-05-2015, 02:32 PM   #1
Gone Wild
 
Join Date: Jan 2012
Location: California
Posts: 267
Default Charger Question

07 Club Car Powerdrive 2 charger. Well I'm pretty sure I know how the charger should work after I plug it in and it seems to be skipping the diagnostic step. After plugging in the charger there is a pause then charger kicks on, amp meter is up 13- 15 holds there, then just a flutter and continues charging. Amp needle does not go to 0 just a flutter about 1/2 amp and back to where it was. Other than that it seems to be working fine.

Should we be concerned about something not working right? Charger problem or OBC problem?
PuttPutt is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-05-2015, 06:05 PM   #2
Cave Dweller
 
Swan's Avatar
Club Car
 
Join Date: Apr 2013
Location: Always On The Move
Posts: 6,718
Default Re: Charger Question

after in bounces back up it then charges completely and goes to zero ? if so i would say your fine charger . My PD2 would do that from time to time.
Swan is offline   Reply With Quote
Unread 12-05-2015, 07:25 PM   #3
Gone Wild
 
Join Date: Jan 2012
Location: California
Posts: 267
Default Re: Charger Question

Thanks Swan, It finishes charging. Just seems odd that it is not doing a diagnostics at the start.
PuttPutt is offline   Reply With Quote
Unread 12-06-2015, 06:36 PM   #4
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,966
Default Re: Charger Question

Newer OBCs do not do the calibration/diagnostics at the start of the charge. If your OBC is grey, which it should be, it won't perform this function. It sounds like it's working normally to me.
TahoeDawgZ71 is offline   Reply With Quote
Unread 12-08-2015, 02:56 AM   #5
Gone Wild
 
Join Date: Jan 2012
Location: California
Posts: 267
Default Re: Charger Question

Sound good to me. If it aint broke don't fix it.

Thanks for the help
PuttPutt is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Charger question Electric Club Car
charger question Electric EZGO
charger question Electric Yamaha
Need help with charger question Electric Yamaha
charger question Electric Club Car


All times are GMT -5. The time now is 05:07 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.