lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-04-2016, 03:08 PM   #1
Not Yet Wild
Club Car
 
Join Date: Oct 2013
Location: Gonzales, La. and Natchez, Ms.
Posts: 30
Default Precedent won't always run

48 volt, 500 amp Altrex, lift kit, 11" tires.
Lately the buggy with stop completely. It may restart immediately, it may not.
Switching reverse switch seemed to help at first, but now it doesn't.
also, some times I plug charger in and it will run all night, and still be charging the next morning. This is with very little run time on charge. Then the next time it will charge 3-4 hrs, then shut off.
Not sure if the two are connected or not.
Don't even want to use buggy any more cause I've lost confidence.
Also, don't have anybody that I know of in the area to work on it.
Any help would be appreciated.
skeetboy is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-04-2016, 06:54 PM   #2
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: Precedent won't always run

This might be off the wall but this happened to me. If the cart rolls a little backward or forward the Alltrax controller will disable the throttle until you come to a complete stop again. This is to prevent damage to the controller sort of like when you tow it. The way to fix this is to go into the software settings and program the brake current to at least 50%. Of course this may not apply to you because you didn't give enough info about your cart. No idea about the charger probably bad batteries.
jjance is offline   Reply With Quote
Unread 01-05-2016, 02:08 AM   #3
Gone Wild
Club Car
 
Join Date: Apr 2014
Location: Oregon City, Or
Posts: 1,938
Default Re: Precedent won't always run

Is this the same '06 cart you've had trouble with every hunting season for the last 2 years?


.
tag50 is offline   Reply With Quote
Unread 01-05-2016, 06:46 AM   #4
Not Yet Wild
Club Car
 
Join Date: Oct 2013
Location: Gonzales, La. and Natchez, Ms.
Posts: 30
Default Re: Precedent won't always run

Yes.....Like I said in post, I'm loosing confidence is this buggy quickly....
skeetboy is offline   Reply With Quote
Unread 01-05-2016, 09:57 AM   #5
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,977
Default Re: Precedent won't always run

Sounds like an MCOR failure. The MCOR is the small black box mounted next to the accelerator pedal under the floor. There is a micro-switch inside the MCOR than can fail. They typically do exactly as you're describing. They'll work for a little while and then quit. Sit for a while and work again, for a little while. They eventually get worse and quit completely. A quick test can determine the problem. Locate the MCOR by removing the floor mat and the access cover underneath the mat. The MCOR will have two plugs plugged into it. One is a 2 pin plug for the micro switch. One is a 3 pin triangular shaped plug for the throttle control. Leave the 3 pin plug in the mcor, unplug the 2 pin plug. Jump the two wires together inside the 2 pin connector with a paper clip and drive your vehicle. If the problem is gone you've found your issue. Replace the MCOR and enjoy your cart.
TahoeDawgZ71 is offline   Reply With Quote
Unread 01-05-2016, 10:26 AM   #6
Gone Wild
 
teecro's Avatar
Club Car
 
Join Date: Jun 2014
Location: Sunset Bay, TN
Posts: 2,214
Default Re: Precedent won't always run

Quote:
Originally Posted by TahoeDawgZ71 View Post
... Sounds like an MCOR failure. The MCOR is the small black box mounted next to the accelerator pedal under the floor....
Another thought to keep in mind is that guys like David Hicks will sell you the best part for your cart not just any part that will work. I found out the hard way when I replaced the MCOR2 in my cart with a brand new MCOR3 and it was nearly as bad if not worce... Installed a MCOR4 from David and my cart has not missed a lick in close to a year now...
teecro is offline   Reply With Quote
Unread 01-05-2016, 11:32 AM   #7
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,977
Default Re: Precedent won't always run

Quote:
Originally Posted by teecro View Post
Another thought to keep in mind is that guys like David Hicks will sell you the best part for your cart not just any part that will work. I found out the hard way when I replaced the MCOR2 in my cart with a brand new MCOR3 and it was nearly as bad if not worce... Installed a MCOR4 from David and my cart has not missed a lick in close to a year now...
Glad to hear it. We have buckets and buckets of MCORs. Very popular item
TahoeDawgZ71 is offline   Reply With Quote
Unread 01-05-2016, 12:19 PM   #8
Gone Wild
 
jjance's Avatar
Club Car
 
Join Date: Feb 2011
Location: Chattanooga TN
Posts: 2,105
Default Re: Precedent won't always run

Quote:
We have buckets and buckets of MCORs. Very popular item
Yes a very unreliable item, Club Car needs to have a recall on this item.
jjance is offline   Reply With Quote
Unread 01-05-2016, 01:49 PM   #9
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,977
Default Re: Precedent won't always run

Quote:
Originally Posted by jjance View Post
Yes a very unreliable item, Club Car needs to have a recall on this item.
They were unreliable, the MCOR4 has proven to be much improved.
TahoeDawgZ71 is offline   Reply With Quote
Unread 01-05-2016, 02:23 PM   #10
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,975
Default Re: Precedent won't always run

I sure hope this don't jinks me, I have a 2003 IQ as far as I know there has been no problem with the mcor. Cart is used almost every day for golf.
mrgolf is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Club Car Precedent Dual Action Heavy Duty Overload Leaf Spring For CC Precedent Electric Club Car


All times are GMT -5. The time now is 12:01 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.