lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-04-2016, 05:06 PM   #1
Not Yet Wild
 
Join Date: Feb 2016
Posts: 1
Default 96 DS 48v loosing power

Ok, here we go. I've got a 96 Club Car DS I use as a hunting cart. Over the past year I doesn't seem to have the power or speed that it used to. (Not to say that it had a lot to begin with) Its got new batteries and cables and all connections are good and clean. I can jack up the rear wheels and run it, Most times it runs, as of late it shudder and quit all together. It will start working again after it sits for a bit. It seems to me to be the motor but I'm not sure. My first question is there a way to check to voltage going to the motor? If I ground the voltage meter to the negative side, all the terminals read about 50 volts. Is this normal?Any other suggestions?
Smackindown is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
89 loosing power when hot Gas EZGO
Loosing power? Electric EZGO
loosing power Electric Club Car
loosing power Electric Club Car
Loosing power Electric EZGO


All times are GMT -5. The time now is 05:39 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.