lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-07-2016, 08:59 PM   #1
Not Yet Wild
 
Join Date: Jan 2014
Posts: 2
Default 99 Regen cutting out while under load randomly

Last weekend at the hunting range my cart started acting up randomly. While under a load it was cutting off on and on almost as if you were turning on and off the key. It was doing this throughout any position of the gas pedal. Doesn't seem to do it while on flat ground as much, but no true rhyme or reason when it does it. I can even do a power brake and make it cutout now. I have checked a few things and have come up with this:
*The drive solenoid was hanging loose from the frame, re-bolted it to the chassis, and checked all wiring. Found the middle wire block on the passenger side of the controller was broken, so replaced it with a new wire running directly to the motor to bypass the regen solenoid. Disconnected rest of the wiring from regen solenoid, and unplugged speed sensor. Cart runs better (faster) while driving, but still randomly cuts on and off.
*F/R switch was clean and tight, cleaned connections
*Battery pack is 5 months old with good voltage on all batteries
*V-glide was clean upon inspection
*Drive solenoid clicks every time the pedal is pressed, can hear an "electrical white noise" coming from the controller
**The only other thing I've noticed is that I replaced the drive solenoid last year with a ebay special. Could the solenoid be overheating or just failing while under load? Cheap solenoid? Solenoid damaged from hanging and not being mounted? Or is the controller on its way out?
Chevybro55 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-07-2016, 09:14 PM   #2
Getting Wild
Club Car
 
Join Date: Dec 2012
Posts: 123
Default Re: 99 Regen cutting out while under load randomly

What is your battery pack condition? Have you checked each battery under a load(check while driving the cart)? Sounds like a bad battery.
wthompson912 is offline   Reply With Quote
Unread 02-07-2016, 09:51 PM   #3
Not Yet Wild
 
Join Date: Jan 2014
Posts: 2
Default Re: 99 Regen cutting out while under load randomly

All batteries test good at rest and under load.
This did start happening after being trailered to the shooting range. Not a rough ride, but that was the first day that its done this. Have owned this cart for 2+ years. Only thing I found was the solenoid hanging loose. I'm thinking something happened to it internally?
Chevybro55 is offline   Reply With Quote
Unread 02-07-2016, 11:03 PM   #4
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,982
Default Re: 99 Regen cutting out while under load randomly

Two simple things to check. Hot wire key switch. Hot wire Run Tow switch.

Switches build up film on contacts and don't make good connections sometimes.
mrgolf is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
how to load test battery if no load tester Electric Club Car
2003 DS IQ 48 volt cutting off under load then limp mode Electric Club Car
Load testing 8V with load tester Electric Club Car
97 CC DS Series Power Cutting Out Randomly Electric Club Car
How to check for voltage, Load or no load? Electric EZGO


All times are GMT -5. The time now is 04:14 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.