lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-21-2016, 07:23 PM   #1
Not Yet Wild
Club Car
 
Join Date: Feb 2016
Location: North Carolina
Posts: 5
Default 08 cc precedent possible speed sensor problem?

Hello. New golf cart owner here. Bought a 08 club car precedent a couple weeks ago. It seems in very good shape....very clean. It has 4-12 volt batteries that are 2 years 4 months old. Haven't ridden cart much until this weekend. I have, during these 2 weeks, removed & cleaned all battery cables & checked water in batteries.

Noticed yesterday that it would get up to speed....then slow down to about 8 mph...then surge back to 14mph.......back & forth. Then, a little later. .....it would only get up to 8mph......never going full speed. Charged batteries last night. This morning, got up to full speed. ....& stayed there for a while. Then.....started speeding up/slowing down again.

Saw the speed sensor sticky.....& performed the test where you push the cart while key is on &switch in forward or reverse. It failed that test..... it didn't beep or apply brake. I feel pretty confident the speed sensor is bad but wanted to get yalls opinions.

Can a speed sensor be an intermittent problem? Also....the reverse buzzer sometimes works & sometimes does not. I didn't think speed sensor would have anything to do w/ reverse buzzer. ....so got me thinking I might have a controller problem?

Thanks for any help!
BCole10 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-21-2016, 07:44 PM   #2
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,025
Default Re: 08 cc precedent possible speed sensor problem?

It's a speed sensor problem. Often, they'll cause intermittent issues before they fail completely. Don't buy a cheap chinese sensor on eBay. Get a factory sensor. We use the factory sensors and never have a reoccuring problem. The Chinese ones are known to fail within days-weeks of installation.
TahoeDawgZ71 is offline   Reply With Quote
Unread 02-22-2016, 09:42 AM   #3
Not Yet Wild
Club Car
 
Join Date: Feb 2016
Location: North Carolina
Posts: 5
Default Re: 08 cc precedent possible speed sensor problem?

Thanks TawhoeDawgz71!

I've read a lot of your posts on here and appreciate your info/expertise!
BCole10 is offline   Reply With Quote
Unread 02-22-2016, 01:07 PM   #4
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,025
Default Re: 08 cc precedent possible speed sensor problem?

Quote:
Originally Posted by BCole10 View Post
Thanks TawhoeDawgz71!

I've read a lot of your posts on here and appreciate your info/expertise!
No problem.
TahoeDawgZ71 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2008 Precedent Replaced Speed Sensor - Problem persists Electric Club Car
08 precedent electric speed sensor problem. Cart starts at proper speed then slows . Electric Club Car
Half speed, speed sensor problem?. Electric Club Car
Speed Sensor Problem Electric EZGO
08 precedent speed sensor Electric Club Car


All times are GMT -5. The time now is 03:20 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.