lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-27-2016, 08:22 PM   #1
Not Yet Wild
Club Car
 
Join Date: Sep 2015
Location: Albuquerque NM
Posts: 67
Default Static from radio when lights are on???

Just finished installing lights, horn and stereo with amp and 4 speakers on my 48V 2006 Club Car DS. Everything works great except that when the radio is on and I turn on the lights, either set I have, I get really bad static. Anyone know what would cause/fix this? Also, when the radio is on and I honk the horn the radio turns off, then starts back up. Have no clue what would cause that! I am not very good with electrical connections but with a lot of help from member Sergio I got it installed! Any help or advice would be greatly appreciated.
Kmart06 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-27-2016, 08:31 PM   #2
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,057
Default Re: Static from radio when lights are on???

you need a rf filter in your power line to radio



are you running a reducer or a battery to power you stuff ?
crash test dummy is offline   Reply With Quote
Unread 02-27-2016, 08:49 PM   #3
Not Yet Wild
Club Car
 
Join Date: Sep 2015
Location: Albuquerque NM
Posts: 67
Default Re: Static from radio when lights are on???

reducer
Kmart06 is offline   Reply With Quote
Unread 02-27-2016, 08:53 PM   #4
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,057
Default Re: Static from radio when lights are on???

over load of reducer would cause radio to cut off

might need a bigger reducer
crash test dummy is offline   Reply With Quote
Unread 02-27-2016, 09:00 PM   #5
Not Yet Wild
Club Car
 
Join Date: Sep 2015
Location: Albuquerque NM
Posts: 67
Default Re: Static from radio when lights are on???

Its a 30 amp reducer and the radio doesn't cut off, it just turns to almost pure static.
Kmart06 is offline   Reply With Quote
Unread 02-27-2016, 09:03 PM   #6
Dazed & Confused
 
crash test dummy's Avatar
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 14,057
Default Re: Static from radio when lights are on???

Quote:
Also, when the radio is on and I honk the horn the radio turns off, then starts back up.
sorry i thought it cut off
filter will help with static
crash test dummy is offline   Reply With Quote
Unread 02-27-2016, 09:05 PM   #7
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 2,978
Default Re: Static from radio when lights are on???

Put a diode in line of the radio power wire, between the diode and radio put a capacitor across neg and pos radio power wires. This will keep other things from pulling power from radio for a few seconds. Works on my GPS that used to turn off when I turned head lights on.
mrgolf is online now   Reply With Quote
Unread 02-27-2016, 09:11 PM   #8
Not Yet Wild
Club Car
 
Join Date: Sep 2015
Location: Albuquerque NM
Posts: 67
Default Re: Static from radio when lights are on???

Quote:
Originally Posted by crash test dummy View Post
sorry i thought it cut off
filter will help with static
I guess I was misleading. The static is caused by the radio, but a separate? problem is that when I honk the horn, the radio DOES turn off. I can have both sets of lights and radio on and the radio wont lose power, but as soon as I push the horn button I lose the radio. Even with both lights OFF and only radio on, the horn kills the radio. SOOO frustrating!
Kmart06 is offline   Reply With Quote
Unread 02-27-2016, 11:02 PM   #9
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 4,583
Default Re: Static from radio when lights are on???

The horn problem is strange, lets check some basics:

The horn is connected to the fuse box, right?

You ran 10ga or better wire from the converter to the Relay N.O. Contact and 10ga wire back to the Fuse box, right?
Sergio is online now   Reply With Quote
Unread 02-27-2016, 11:09 PM   #10
Not Yet Wild
Club Car
 
Join Date: Sep 2015
Location: Albuquerque NM
Posts: 67
Default Re: Static from radio when lights are on???

Quote:
Originally Posted by Sergio View Post
The horn problem is strange, lets check some basics:

The horn is connected to the fuse box, right?

You ran 10ga or better wire from the converter to the Relay N.O. Contact and 10ga wire back to the Fuse box, right?
Yes, the horn is connected to a relay which is then connected to the fuse box. The green wire from the converter to the relay is definately not 10 gauge, probably 12 or 14, but it is what came on the converter. The wire from the relay to the fuse box is 14 gauge, I didn't know I would need bigger wire. I will upgrade that to 10 gauge tomorrow.
Kmart06 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Radio static. Electric EZGO
Elite dash radio static Electric Club Car
Radio static? Electric Club Car
Radio Static Electric Club Car
Radio static Electric EZGO


All times are GMT -5. The time now is 05:39 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.