lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-05-2016, 04:47 PM   #1
Not Yet Wild
 
Join Date: Feb 2016
Posts: 8
Default Solid state conversion problem

Im finally done with my solid state conversion on my Royal Ride ('88 club car chassis), but Im confused as to the correct wiring for the high current connections. The dealer who sold me the Curtis 1205-5603 controller gave me a diagram to follow(attached), but something isn't right.

The car will run briefly, but then the controller seems to go into a protect mode of some sort and I have to cycle the key off for a minute before it will go again. I tested everything from each contactor to the potbox and all checks out. The only issue I see is when testing voltage across B+ and M- I get nothing when the pedal is depressed.

Th D&D motor says:

Connect S2 and A1 together
Connect S1 to battery terminal
Conmect A2 to other battery terminal

Anyone know which is the correct wiring? I'm new to EV wiring, not sure where to go on this one. Any help is much appreciated!
Attached Images
File Type: jpg image.jpg (76.3 KB, 0 views)
Dieselnut is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-05-2016, 05:59 PM   #2
Not Yet Wild
 
Join Date: Feb 2016
Posts: 8
Default Re: Solid state conversion problem

Both the main and the f/r contactor click, but motor won't turn when the problem happens. If I wait 2 minutes, even without cycling the key, it will work again.

Frustrated to say the least....anything I can test for? Problem is that I only have less than 2 minutes to use my meter and test before it starts working again.
Dieselnut is offline   Reply With Quote
Unread 03-05-2016, 07:27 PM   #3
Not Yet Wild
 
Join Date: Feb 2016
Posts: 8
Default Re: Solid state conversion problem

Hooked up status LED. It will run 4-5 drive cycles then will stop and flash code 2,3 twice (which is for HPD lockout) then goes to code 1,4(which is a generic wiring problem.

I thought maybe the keyswitch was bad so I bypassed it, same problem. Could it be a bad potbox or microswitch? Just not sure how to test, as the problem is somewhat intermittent.

Anyone have any ideas of where to go from here?
Dieselnut is offline   Reply With Quote
Unread 03-07-2016, 09:47 AM   #4
Gone Wild
Club Car
 
Join Date: Feb 2012
Location: Indio, CA The Desert!
Posts: 1,177
Default Re: Solid state conversion problem

You said you connect S2 and A1 together? I don't see that on your diagram, and also i don't believe i've seen that before?
smokey tennis shoe is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Problems during solid state conversion Electric Club Car
86 club car ds solid state conversion Electric Club Car
Yamaha G2E solid state conversion Electric Yamaha
G2 solid state conversion Electric Yamaha
G2 f/r on a solid state conversion Electric Yamaha


All times are GMT -5. The time now is 10:56 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.