lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-07-2009, 05:21 PM   #1
Not Yet Wild
Club Car
 
Join Date: Jan 2009
Location: Texas
Posts: 26
Default Charging problem

Hello , I have a 95 model Club Car . I replaced all batteries & cables . When charger is plugged in nothing happens .
timsdsl is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-08-2009, 09:55 AM   #2
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Charging problem

Was this the case before you replaced the Cables and Batteries ?
If it worked before then you either have Bad NEW Battery or you have a RE-Wiring problem.
Re-wiring is the most common Prob.

Is this a 36V or 48V system (Cart and charger) we had 1 guy yesterday with a 48 Volt
system , he did just what you did but insted of buying 6 8Volt Batteries (48 Volt) he
had purchased 6 6Volt batteries (36 Volt) so his 48 Volt charger would not come on.
GLEEMO is offline   Reply With Quote
Unread 01-09-2009, 08:42 AM   #3
Not Yet Wild
Club Car
 
Join Date: Jan 2009
Location: Texas
Posts: 26
Default Re: Charging problem

Thanks for your reply , my car is a 48 volt . Yes the batteries are 8 volt .the has sat for about 9 yrs . when set up batts. were bad . My family & I all have 4-wheelers and are very active all the time . My youngest one wanted it fixed . Well we replaced the batts & cables , wired it to spec . Replaced solenoid , & had charger looked at . All is correct . ready to try anything.
timsdsl is offline   Reply With Quote
Unread 01-09-2009, 08:50 AM   #4
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,043
Default Re: Charging problem

9 Yrs is a long time for mice and corrosion to get in there and do their damage. Grab a wiring diagram and a voltmeter....Is there another working cart around you can check the charger on or a repair shop that can verify the charger is in working order?
scottyb is online now   Reply With Quote
Unread 01-09-2009, 09:23 AM   #5
Not Yet Wild
Club Car
 
Join Date: Jan 2009
Location: Texas
Posts: 26
Default Re: Charging problem

Hello scotty , the charger has been repaired & works on other carts. I have no wiring problems such as mice or corrosion . When jump the charger plug ground to battery ground it used to work but wont now .
timsdsl is offline   Reply With Quote
Unread 01-09-2009, 09:33 AM   #6
Not your usual outlaw
 
essness's Avatar
Yamaha
 
Join Date: Oct 2008
Location: Near Lake Geneva, WI
Posts: 19,854
Default Re: Charging problem

Is it possible that the new batteries dont have enough juice to start the charger?
essness is offline   Reply With Quote
Unread 01-09-2009, 09:54 AM   #7
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Charging problem

Sorry for this ? , just in case I missed something BUT
why did U used to have to "jump the charger plug ground to battery ground" to get it to
work ??
GLEEMO is offline   Reply With Quote
Unread 01-09-2009, 10:20 AM   #8
Not Yet Wild
Club Car
 
Join Date: Jan 2009
Location: Texas
Posts: 26
Default Re: Charging problem

Theres a cart repair shop close by , they told me to test the charge circuit that way to see if it is something other than the charger . When i first did it it worked well , charged fully . But then it would not charge again .
timsdsl is offline   Reply With Quote
Unread 01-09-2009, 06:17 PM   #9
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: Charging problem

I would guess your on board computer might be the problem. Your charger does not have a separate on/off switch, its triggered by a computer on the car.
phasetim is offline   Reply With Quote
Unread 01-09-2009, 07:49 PM   #10
Not Yet Wild
Club Car
 
Join Date: Jan 2009
Location: Texas
Posts: 26
Default Re: Charging problem

Thanks phase , that answers my other ? I was told there was a computer in the charger as well . So the obc is the possible prob . ?
timsdsl is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Charging Problem Electric EZGO
charging problem? Gas Club Car
Problem with charging? Electric Club Car
A 48v charging problem Electric Club Car
charging problem Gas Club Car


All times are GMT -5. The time now is 10:19 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.