lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-10-2009, 01:04 PM   #11
Getting Wild
Club Car
 
Join Date: Jan 2009
Location: Work or home
Posts: 76
Default Re: Charger not doing anything.... bad batteries

3 months later.

I finally got around to working on the kart. First, it has 6 batteries, not 8.

The voltages on the non-trojan batteries was .5, so those got replaced.

Now I have 6 trojan batteries. The voltages for the new ones are 8.2.

Other voltages are
2.3
7.2 (wiring problem?)
2.7
3.8

The kart has not been charged in 6 months.

I was using an ohm meter touching the post on the batteries. The one that has 7.2 came up with nothing touching the post. So I touch the wires that are on the post and it came up with that. I was going to clean the wires so I took them off. The wires were wrapped around the post (no attachments for the post). After I took that off, I could touch the post and get 7.2.

I don't know much at all, but could this mean the battery was never being used? I am going to replace the cables on that one, but I still don't think its going to charge.

I have read online that if the batteries are too low it won't charge. I also read that you can use a car battery charger and charge 2x6volt batteries. Could I do the same thing with 2x8volt batteries, or would that not work?

oh yea. I ran the cables just to the two new batteries and the charger did nothing. I don't know if it should have, but I was trying to troubleshoot.

by-passed relay and the charger was humming, but that was the only thing it was doing. The amp needle did not move. edit: Did not have all the batteries hooked up. Hooked them up and its hitting 2 amps
mustangless is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-10-2009, 03:26 PM   #12
Gone Wild
 
Otter70's Avatar
E-Z-GO
 
Join Date: Feb 2008
Location: Virginia Beach, Virginia
Posts: 234
Default Re: Charger not doing anything.... bad batteries

First off, let me say that owning, upgrading, restoring a golf cart is somewhat expensive. When I got mine my cart my batteries were in better shape than yours seem to be. I found this forum and after reading some posts I decided to go with a whole new pack. Regretfully I didn't go with Trojans though. I bought 6 new Deka GC10 6 volts and I was very happy with them. A few months ago I added 2 more of the Deka's to upgrade to 48 volts.

Finally Did It!!

You should get 4 more. You'll be glad ya did
Otter70 is offline   Reply With Quote
Unread 04-11-2009, 05:40 PM   #13
Getting Wild
Club Car
 
Join Date: Jan 2009
Location: Work or home
Posts: 76
Default Re: Charger not doing anything.... bad batteries

Is there not any chance these are dead only from not being charged for half a year? I don't want to spend over $400 if I don't have to?

I am thinking about getting a new relay, am I correct in believing this is bad since when I bypass it, the charger works?

I will buy the batteries but I don't want to if these are only dead from not being charged. This is why I think I have a charger problem.
mustangless is offline   Reply With Quote
Unread 04-11-2009, 09:00 PM   #14
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,079
Default Re: Charger not doing anything.... bad batteries

Stop don't do anything! I'll be right back.....not a charger problem I'm gonna say this slow and with alittle more explanation....
1st. Don't experiment. You are playing around with what is probably a perfectly good $400 battery charger.....the batteries themselves have enough amperage to weld or vaporize metal if shorted. Be careful!
2. Dude. Your batteries are DEAD. Toast. Gone. I'm sorry they just can't take being left empty that long.... You may be able to revive the 7.2 but you can't run it in a pack of new batteries with out it making the charger over-charge and cook the new batteries. This will shorten the life of the new ones so not worth it!
3. put the cover back on the charger it is doing exactly what it is designed to do.....I hope this helps.
4. You were smart enough to come here asking for help... we gave good advice. Now, be smart enough to take it
scottyb is offline   Reply With Quote
Unread 11-05-2009, 03:46 PM   #15
Not Yet Wild
 
blkt6's Avatar
Club Car
 
Join Date: Nov 2009
Location: Jupiter,Fl
Posts: 19
Default Re: Charger not doing anything.... bad batteries

Did the new batteries work? update
blkt6 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Changed batteries/batteries won't charge Electric Club Car
Club Car battery charger won't charge new batteries Electric golf carts
Charging batteries with a 12 volt charger Electric EZGO
dead batteries/bad charger Electric Club Car


All times are GMT -5. The time now is 06:44 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.