lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-09-2009, 03:59 PM   #1
Getting Wild
Club Car
 
Join Date: Jan 2009
Location: Work or home
Posts: 76
Default Charger not doing anything.... bad batteries

My cart has 6 trojan batteries, 1 exide, and 1 other. The non trojan batteries are only showing .5 volts. When I plug the charger to the cart, it does nothing. The cart is dead, it will make a buzz noise in reverse, but won't move an inch. I had no clue about taking care of batteries until a month ago. That is when I found out the were mostly out of water.

If I am reading correctly, the bad batteries could be causing the charging problem.

I don't know what batteries to replace with. The trojans only say "T Power Drive"

I only see t-875, t860, etc online.
mustangless is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-09-2009, 05:03 PM   #2
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,060
Default Re: Charger not doing anything.... bad batteries

Replace them all.....
Post the voltages from each individual and we can tell more...
scottyb is offline   Reply With Quote
Unread 01-09-2009, 06:15 PM   #3
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: Charger not doing anything.... bad batteries

replacing them as a pack is the best and least troublesome method.
phasetim is offline   Reply With Quote
Unread 01-09-2009, 10:52 PM   #4
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: Charger not doing anything.... bad batteries

Welcome to the forum mustangless.............
rusty is offline   Reply With Quote
Unread 01-09-2009, 11:20 PM   #5
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,912
Default Re: Charger not doing anything.... bad batteries

The batteries are toast. Don't bother trying to charge, revive, restore, fix or repair them. If some are reading .5 volts they are too far gone. Replace the whole pack and enjoy yourself.
roady89 is offline   Reply With Quote
Unread 01-10-2009, 08:47 AM   #6
Gone Wild
 
mikesmotortoys's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Rockwall, Texas (Dallas / Ft. Worth)
Posts: 7,077
Default Re: Charger not doing anything.... bad batteries

What cart do you have? There aren't too many out there with 8 - 6 volt batteries, unless you have an EZGO Industrial model. Could also be a home made 48 volt?

Factory EZGO - Bad Boy Buggy - Dixie Chopper Mowers
mikesmotortoys is offline   Reply With Quote
Unread 01-10-2009, 11:59 AM   #7
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Charger not doing anything.... bad batteries

Good catch mike ,
If this is a home conversion it would explain why the 2 aren't Trojans, and if they are in
the bag well , why they were not maintaned.

"MustangLess Post readings for all batteries here !
and a picture may help :)
GLEEMO is offline   Reply With Quote
Unread 01-12-2009, 08:34 AM   #8
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: Charger not doing anything.... bad batteries

some new Carryalls have that setup as well... They now say its a stronger system.. That should make all the EZGO folks boast a little. lol.
phasetim is offline   Reply With Quote
Unread 01-12-2009, 09:16 AM   #9
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,060
Default Re: Charger not doing anything.... bad batteries

So you say the new Carryalls have eight 6v batteries? It stands to reason that if you have more lead you can store more amps...
scottyb is offline   Reply With Quote
Unread 01-12-2009, 11:31 AM   #10
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Charger not doing anything.... bad batteries

Mustangless , look at the battery comparison in the sticky http://www.buggiesgonewild.com/electric-club-car/
GLEEMO is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Changed batteries/batteries won't charge Electric Club Car
Club Car battery charger won't charge new batteries Electric golf carts
Charging batteries with a 12 volt charger Electric EZGO
dead batteries/bad charger Electric Club Car


All times are GMT -5. The time now is 06:32 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.