lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-20-2016, 02:17 PM   #1
Getting Wild
 
eagant5's Avatar
Club Car
 
Join Date: Jan 2009
Posts: 102
Default 87 ds running slow

Hi, I have an 87 club car ds that I just put new batteries in. The car is slow and has no torque or power. Where's the best place to start to find the issue. I checked motor voltage and the highest voltage I seen is 32.7 full throttle with the cart on jack stands.
eagant5 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-20-2016, 05:33 PM   #2
Gone Wild
Club Car
 
Join Date: Apr 2014
Location: Oregon City, Or
Posts: 1,940
Default Re: 87 ds running slow

Double check the battery cables. At that voltage it sounds like you're missing a battery. Either one turned around or tapped into only 5 batteries.

Also, batteries are sold with only a 75% charge. Always give a full charge to replacements.

.
tag50 is online now   Reply With Quote
Unread 04-20-2016, 06:22 PM   #3
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 2,682
Default Re: 87 ds running slow

Measure all of your battery volts and the total pack volts. Look for a miswire if you just installed new batteries. Your total volts should be way higher - over 39V. Always do a full charge before using new batteries.
Volt_Ampere is offline   Reply With Quote
Unread 04-20-2016, 06:31 PM   #4
Getting Wild
 
eagant5's Avatar
Club Car
 
Join Date: Jan 2009
Posts: 102
Default Re: 87 ds running slow

Pack voltage is right at 38.7. Going to charge it tonight but I don't think that's my issue as the cart acted the same way with the old batteries. Everything seems wired correctly.
eagant5 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
78 g1 running slow Gas Yamaha
EZGO TXT running very slow Electric EZGO
Cart running very slow Electric Club Car
95 CC Running Slow Electric Club Car


All times are GMT -5. The time now is 01:45 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.