lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars

Post New Thread  Reply
Thread Tools Display Modes
Unread 04-21-2016, 02:30 PM   #1
Not Yet Wild
Club Car
Join Date: Jun 2009
Location: Two states
Posts: 36
Default 95 Cub Car DS 48v wont move

Picked up a neighbors cart as they were having issues with it and wanted it gone. Its also a 95 DS 48 volt version A9527-442898

Noticed they had constantly had the charger on and along with 2 bad batteries, all the battery rods were disintegrated, had layers of layer of corrosion on cart frame and other areas. They leave the charger on 24x7 since this sits at lake house.

Brought cart home and checked all the batteries and 2 out of 6 failed voltage reads with about 2 and 3 v each. Pulled the batteries and neutralized all the acid seepage. Cleaned all the frame of corrosion and picked up 2 new batteries and ordered the rods and nuts. Luckily the terminals all had a thick brown greasy anti corrosion coating on them and only 3 are bad. I replaced those with new cables, cleaned all the others an put cables back on.

Cart will read close to 56v on full pack I after I charged it and drops to about 52 when solenoid clicks but cart wont move at all. I jacked rear wheels off the ground and jumped the solenoid large terminals with key off and then turned key on and pushed pedal and still had no wheel movement. I checked and cleaned connections on F/R switch and they all appear fine. I cleaned all the terminals on the motor and cable ends and put back on respective posts.

Pulled cable to controller and resistor off one side of relay and put volt meter from #6 battery and to relay and pushed pedal with key on. Got full 56v off relay to controller-Yellow line side of relay on pedal push so solenoid is passing power.

I can pull all the leads off the motor and jumper A1 and S1 together and then Jumper A2 and S2 together. I can hook jumper cables to A1/SA and then other lead to A2/S2 and then run to 12v battery as small power source and I WILL get slow motor turn so I know motor is operable.

Checked power through micro switch on F/R switch and pressed pedal and get full voltage through circuit with pedal depressed and drops back off upon release.

Unit appears to have a newer OBC as its tags are dated 2008 or 2009 but smudged.

What else can I check to rule out the OBC. Controller or still even motor? Best part would be how as its been a bit since I rebuilt ours with new motor. controller after son had lake mishap..

Lake Rider is offline   Reply With Quote
Alt Today

Golf car forum Sponsored Links

This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car

Thread Tools
Display Modes

Similar Threads
Thread Forum
G29 wont move Electric Yamaha
wont move Gas Harley Davidson
Ezgo dcs solenoid clicks but wont disengage and wont move Electric EZGO
98 ds wont move Electric Club Car
sometimes wont move Electric EZGO

All times are GMT -5. The time now is 02:19 PM.

Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.