lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-25-2016, 04:29 PM   #1
Not Yet Wild
 
Join Date: Apr 2016
Posts: 5
Default Flashers not working with headlights on

I have a strange problem here - have a 2005 Club Car, and recently installed a new flasher (EL 13, 11-15v DC 3 terminal) to get the flashers and turn signals working.
We just now noticed that once the headlights are turned on, the flashers stop working, as well as driver side front and back turn signals. They light up, but don't blink. Yet on the passenger side, both front and rear signals work fine with headlights on...
Any ideas what might be happening? Was this the correct flasher? The old one was a "Flasher super wide FR-9E 12v 32 CP 23w"

Please be somewhat specific, this is all new to us, learning as we go..

Thanks to all!
atdelane is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Headlights not working Electric EZGO
Headlights and taillights - not working Gas Club Car
Headlights not working Electric Club Car
96 ezgo headlights not working Electric EZGO
Headlights aren't working Electric Club Car


All times are GMT -5. The time now is 10:59 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.